Bug 729045 - Debug file missing in debuginfo package for a binary
Summary: Debug file missing in debuginfo package for a binary
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nmap
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Patrik Kis
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 727919
TreeView+ depends on / blocked
 
Reported: 2011-08-08 15:20 UTC by Karel Klíč
Modified: 2014-01-30 09:21 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-05-30 15:49:09 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0881 normal SHIPPED_LIVE nmap bug fix update 2013-05-30 19:48:16 UTC

Description Karel Klíč 2011-08-08 15:20:59 UTC
A problem related to debuginfo was found in the nmap-5.21-4.el6 package. This issue might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

A debuginfo file for a binary is not present in the debuginfo package. This might be caused by:
 - binary being compiled without debugging information
 - debugging information being removed from the binary by a build script
 - rpmbuild failing to extract debugging information from a binary in a buildroot because of permissions (eg. suid binaries, binaries without executable flag set)

affected binary: /usr/bin/ncat
affected package: nmap-5.21-4.el6.i686
binary doesn't contain debug sections (it was probably stripped)
affected binary file mode: 100755

This issue can be investigated by using eu-readelf tool from the elfutils package. Use `eu-readelf --notes /path/to/binary` to get build ID of a binary. Then check that the debuginfo package does not contain /usr/lib/debug/.build-id/<aa>/<bbbbbbbb>, where <aa> are the first two chars of the build ID, and <bbbbbbbb> is the rest of it. It should be a symlink pointing back to the binary.

(This bug was detected and filed by a script.)

Comment 2 RHEL Product and Program Management 2011-08-08 15:41:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 Michal Hlavinka 2012-06-05 11:12:31 UTC
When working on bug #826601, I found that debuginfo subpackage now contains 
$ file /usr/lib/debug/usr/bin/ncat.debug 

/usr/lib/debug/usr/bin/ncat.debug: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=0xc2eca09088e295c06268a3fe8b1f450aba030c81, not stripped

but gdb still does not work:
warning: "/usr/lib/debug/usr/bin/ncat.debug": separate debug info file has no debug info

So, this bug has some improvement, but it's still not fixed.

Comment 10 Michal Hlavinka 2012-06-05 12:26:05 UTC
simple fix is to use
%install
make STRIP=true
so 'strip' is replaced by 'true' command. It's verified on Fedora

Comment 17 errata-xmlrpc 2013-05-30 15:49:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0881.html


Note You need to log in before you can comment on or make changes to this bug.