Bug 729069 - Augeas-based plugins: "Failed to initialize Augeas Java API." errors due to failure to find lens files
Augeas-based plugins: "Failed to initialize Augeas Java API." errors due to f...
Status: CLOSED DUPLICATE of bug 751765
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.1
Unspecified Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Mike Foley
:
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2011-08-08 12:29 EDT by Ian Springer
Modified: 2013-08-05 20:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL
Last Closed: 2011-11-18 03:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-08-08 12:29:45 EDT
In the Agents running in the perf environment, I see the following messages repeatedly in the Agent logs for all of the Augeas-based plugins:

2011-08-08 10:01:43,832 WARN  [ConfigurationManager.threadpool-1] (rhq.core.pc.configuration.ConfigurationCheckExecutor)- Unable to check for updated configuration
java.lang.Exception: Failed to initialize Augeas Java API.
        at org.rhq.plugins.augeas.AugeasConfigurationComponent.abortIfAugeasNotAvailable(AugeasConfigurationComponent.java:717)
        at org.rhq.plugins.augeas.AugeasConfigurationComponent.loadResourceConfiguration(AugeasConfigurationComponent.java:142)
        at sun.reflect.GeneratedMethodAccessor76.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:537)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:662)
2011-08-08 10:01:43,833 ERROR [ResourceContainer.invoker.daemon-2158] (org.rhq.plugins.cron.CronTabComponent)- Failed to initialize Augeas Java API.
java.lang.IllegalStateException: Augeas modules didn't load cleanly.
Module 'Cron' failed with the following errors:
Can not find lens Cron.lns


        at org.rhq.plugins.augeas.AugeasConfigurationComponent.checkModuleErrors(AugeasConfigurationComponent.java:747)
        at org.rhq.plugins.augeas.AugeasConfigurationComponent.createAugeas(AugeasConfigurationComponent.java:358)
        at org.rhq.plugins.augeas.AugeasConfigurationComponent.initAugeas(AugeasConfigurationComponent.java:700)
        at org.rhq.plugins.augeas.AugeasConfigurationComponent.abortIfAugeasNotAvailable(AugeasConfigurationComponent.java:715)
        at org.rhq.plugins.augeas.AugeasConfigurationComponent.loadResourceConfiguration(AugeasConfigurationComponent.java:142)
        at sun.reflect.GeneratedMethodAccessor76.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:537)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:662)
Comment 1 Lukas Krejci 2011-08-08 12:32:26 EDT
<ips> does that mean the *.lns files are inside the respective plugin jars?
<lkrejci> yep
<ips> ok, let me check if that's the case
<ips>     30 Thu Jul 28 18:54:22 EDT 2011 META-INF/augeas-lenses/list
<ips>   1771 Thu Jul 28 18:54:22 EDT 2011 META-INF/augeas-lenses/samba.aug
<ips>   7230 Thu Jul 28 18:54:22 EDT 2011 META-INF/augeas-lenses/inifile.aug
<ips>   2202 Thu Jul 28 18:54:22 EDT 2011 META-INF/augeas-lenses/util.aug
<lkrejci> how's that possible
<ips> that looks like them. but the code seems to be looking for Samba.lns, not samba.aug
<lkrejci> the tests for augeas plugins run their own plugin container so they're using the actual lenses in the plugin jars.. i wonder why hudson doesn't complain
<lkrejci> Samba.lns is inside the samba.aug
<ips> ah
Comment 2 Lukas Krejci 2011-11-18 03:01:42 EST

*** This bug has been marked as a duplicate of bug 751765 ***

Note You need to log in before you can comment on or make changes to this bug.