Bug 751765 - RHQ Agent crashes with Java 1.7
RHQ Agent crashes with Java 1.7
Status: CLOSED UPSTREAM
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.3
x86_64 Linux
medium Severity unspecified (vote)
: ---
: RHQ 4.3.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
: 729069 (view as bug list)
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2011-11-07 09:08 EST by trash
Modified: 2011-11-30 11:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-08 13:23:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump from java crash (48.65 KB, text/plain)
2011-11-07 09:08 EST, trash
no flags Details
dump with java 6 (50.72 KB, application/octet-stream)
2011-11-07 09:17 EST, trash
no flags Details

  None (edit)
Description trash 2011-11-07 09:08:59 EST
Created attachment 532046 [details]
dump from java crash

Description of problem:

RHQ Agent crashes with Java 1.7

I'm running under ubuntu with Java 1.7 and rhq from git (4.3.0-SNAPSHOT):

I uploaded my own plugin. The plugin is available at my server without any errors. 

./rhq-agent.sh
plugins update

and java crashes.

A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f1d228ad050, pid=15339, tid=139763240589056
#
# JRE version: 7.0_147-b147
# Java VM: OpenJDK 64-Bit Server VM (21.0-b17 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea7 2.0pre
# Distribution: Ubuntu oneiric (development branch), package 7~b147-2.0~pre6-1ubuntu1
# Problematic frame:
# C  0x00007f1d228ad050
[error occurred during error reporting (printing problematic frame), id 0xb]


In attachment is a generated dump.
Comment 1 trash 2011-11-07 09:17:40 EST
Created attachment 532050 [details]
dump with java 6
Comment 2 trash 2011-11-07 09:18:36 EST
I can reproduce it with java 6. Dump with java 6 is in attachement

> plugins update
The plugin container has been stopped.
Updating plugins to their latest versions.
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f9948c36050, pid=18535, tid=140296457144064
#
# JRE version: 6.0_23-b23
# Java VM: OpenJDK 64-Bit Server VM (20.0-b11 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.11pre
# Distribution: Ubuntu oneiric (development branch), package 6b23~pre10-0ubuntu5
# Problematic frame:
# C  0x00007f9948c36050
[error occurred during error reporting (printing problematic frame), id 0xb]
Comment 3 Lukas Krejci 2011-11-08 06:17:25 EST
Note that this has been intentionally fixed only in master because JON3 doesn't bundle any of the affected community plugins.

commit dc04043dbfc3f54d922e7c47e4889dcba06947dc
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Nov 8 12:06:53 2011 +0100

    [BZ 751765] Use the correct classloader for obtaining the bundled lens files
    for the augeas based plugins.
Comment 4 Lukas Krejci 2011-11-18 03:01:43 EST
*** Bug 729069 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.