Bug 729111 - Some notifications not properly handling unicode characters
Summary: Some notifications not properly handling unicode characters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Shannon Hughes
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 736791
Blocks: 709813 katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-08 18:25 UTC by Corey Welton
Modified: 2019-09-26 13:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:51:51 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-08-08 18:25:26 UTC
Description of problem:
This might be a regression - I thought this was fixed at some point - but I'm seeing it rear its ugly head (again).

Some notifications are rendering garbage when trying to display multibyte characters.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new org called 你好.
2. Refresh orgs page (to assure it's actually there)
3. Attempt to delete
  
Actual results:
404 Resource Not Found: {"displayMessage":"owner with key: ä½ å¥½ was not found."}

Expected results:

404 Resource Not Found: {"displayMessage":"owner with key: 你好 was not found."}
Generally speaking, notifications should be unicode-friendly.

Additional info:

I am going to make this block bug #709813 because I don't currently know of another way to test such a scenario. But we should try to get this fixed once and for all, across the notifications code.

if I find this to actually be a dupe (i.e., the other was never fixed) i will close it.

Comment 1 Shannon Hughes 2011-09-08 17:25:27 UTC
this error is occuring because we have to url encode the restful call for DELETE actions. Candlepin can not lookup the org record since the actual key they are using does not match up with the Org/Owner. I need to discuss this with some of the CP devs to come up with a gameplan on how to handle.

Comment 2 Shannon Hughes 2011-09-30 18:33:52 UTC
please retest. CP had to upgrade resteasy to fix this.

Comment 3 Corey Welton 2011-10-03 19:50:44 UTC
I'm going to mark this verified. I can't repro anymore - I seem to be able to delete unicode orgs now.  Can reopen if it appears again


Note You need to log in before you can comment on or make changes to this bug.