Bug 729269 - Some Logitech webcams audio device not initialized properly
Some Logitech webcams audio device not initialized properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
: 729278 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-09 06:33 EDT by Tomas Smetana
Modified: 2013-05-17 13:29 EDT (History)
16 users (show)

See Also:
Fixed In Version: kernel-2.6.40.3-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 17:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for Logitech HD Webcam C310 (676 bytes, patch)
2011-08-09 06:39 EDT, Tomas Smetana
no flags Details | Diff

  None (edit)
Description Tomas Smetana 2011-08-09 06:33:17 EDT
Description of problem:
The microphone integrated to some Logitech webcams (Logitech HD Webcam C310 in my case) stopped working after upgrade to 2.6.39: it fails to initialize with the following error in the logs:

Aug  9 08:17:15 saiph kernel: [   13.301613] ALSA sound/usb/clock.c:227 3:3:2: cannot set freq 24000 to ep 0x86
Aug  9 08:17:15 saiph kernel: [   13.438213] ALSA sound/usb/clock.c:242 current rate 290 is different from the runtime rate 32000

Version-Release number of selected component (if applicable):
kernel-2.6.40-4.fc15.x86_64

How reproducible:
Always (with my webcam)

Steps to Reproduce:
1. Try to record something using the integrated microphone on the webcam
2. Replay the sound
  
Actual results:
"chipmunk" sound

Expected results:
more or less the what i have recorded

Additional info:
This is a known regression: https://bugzilla.kernel.org/show_bug.cgi?id=35922 where one can see the patch for Logitech HD Webcam C270 attached.  I'll add the patch for C310 I'm using on my machine right now (and which fixes the problem).
Comment 1 Tomas Smetana 2011-08-09 06:39:01 EDT
Created attachment 517377 [details]
Patch for Logitech HD Webcam C310

This is the patch for my webcam (0x046d:0x081b). It's based on https://bugzilla.kernel.org/attachment.cgi?id=64722 attached to the referenced upstream bug.  According to the Arch Linux forum posts at https://bbs.archlinux.org/viewtopic.php?id=121607 the same code works also for other Logitech web cameras affected by the problem:
0x046d:0x0825 (Logitech C270), 0x046d:0x0809 (Logitech Webcam Pro 9000) and maybe others...

Would be nice if we could have the patch included in the F-15+ since it's a regression.
Comment 2 Josh Boyer 2011-08-09 07:50:00 EDT
*** Bug 729278 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2011-08-09 08:28:13 EDT
I took the upstream patch submissions and combined them to cover C250, C270, and C310 models.  Could you try this kernel when the build completes?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3261724
Comment 4 Tomas Smetana 2011-08-09 10:28:14 EDT
Hello,
  I tested the kernel from koji and it seems to be working OK for me (microphone works as expected).  I still see some the same messages in the log on boot though:

Aug  9 16:13:21 saiph kernel: [   13.760088] ALSA sound/usb/clock.c:227 3:3:1: cannot set freq 16000 to ep 0x86
Aug  9 16:13:21 saiph kernel: [   13.897718] ALSA sound/usb/clock.c:242 current rate 290 is different from the runtime rate 24000
Aug  9 16:13:21 saiph kernel: [   13.906083] ALSA sound/usb/mixer.c:794 5:2: cannot get min/max values for control 2 (id 5)
Aug  9 16:13:21 saiph kernel: [   13.906282] usbcore: registered new interface driver snd-usb-audio

I've tried to unplug/plug the webcam few times. The log contains this:

Aug  9 16:16:16 saiph kernel: [  189.901217] usb 2-1.1: USB disconnect, device number 3
Aug  9 16:16:20 saiph kernel: [  194.161540] usb 2-1.1: new high speed USB device number 6 using ehci_hcd
Aug  9 16:16:20 saiph kernel: [  194.464290] usb 2-1.1: New USB device found, idVendor=046d, idProduct=081b
Aug  9 16:16:20 saiph kernel: [  194.464295] usb 2-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=2
Aug  9 16:16:20 saiph kernel: [  194.464299] usb 2-1.1: SerialNumber: 1F9E6AA0
Aug  9 16:16:20 saiph kernel: [  194.468227] uvcvideo: Found UVC 1.00 device <unnamed> (046d:081b)
Aug  9 16:16:20 saiph kernel: [  194.564788] input: UVC Camera (046d:081b) as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input14
Aug  9 16:16:21 saiph kernel: [  195.561641] ALSA sound/usb/clock.c:227 6:3:1: cannot set freq 16000 to ep 0x86
Aug  9 16:16:21 saiph kernel: [  195.699871] ALSA sound/usb/clock.c:242 current rate 290 is different from the runtime rate 24000
Aug  9 16:16:21 saiph kernel: [  195.708072] ALSA sound/usb/mixer.c:794 5:2: cannot get min/max values for control 2 (id 5)

However recording with arecord and some other apps works well so I suppose the problem is fixed at least for me.

Thank you and regards.
Comment 5 Martin Kho 2011-08-10 03:18:22 EDT
Hi,

This kernel works fine for me too, but I didn't have any problems with my webcam in fc15 :-). Fedora 16 refuses to install this kernel, so I can't definitely say if it solves my issue.

Thanks,

Martin Kho
Comment 6 Fedora Update System 2011-08-16 08:46:10 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 7 Martin Kho 2011-08-16 13:37:41 EDT
Hi Josh,

Grabbed kernel-3.1.0-0.rc2.git0.1.fc16.x86_64 from koji. This build solved the issue I had in Fedora 16.

Thanks,

Martin Kho
Comment 8 Josh Boyer 2011-08-16 13:39:48 EDT
(In reply to comment #7)
> Hi Josh,
> 
> Grabbed kernel-3.1.0-0.rc2.git0.1.fc16.x86_64 from koji. This build solved the
> issue I had in Fedora 16.

Thanks for testing!
Comment 9 Fedora Update System 2011-08-16 21:16:54 EDT
Package kernel-2.6.40.3-0.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40.3-0.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-08-17 22:29:05 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Raul Bras 2011-09-06 09:41:01 EDT
The new kernel does not work with Logitech pro 9000. The micro sound looks like a "chipmunk".
The kernel messages are the following:
ALSA sound/usb/mixer.c:794 5:2: cannot get min/max values for control 2 (id 5)
ALSA sound/usb/mixer.c:1149 set resolution quirk: cval->res = 384

Maybe the pro 9000 has been forgotten in the patch?

Thank you and regards,

Raul Bras
Comment 12 Josh Boyer 2011-09-06 09:57:03 EDT
(In reply to comment #11)
> The new kernel does not work with Logitech pro 9000. The micro sound looks like
> a "chipmunk".
> The kernel messages are the following:
> ALSA sound/usb/mixer.c:794 5:2: cannot get min/max values for control 2 (id 5)
> ALSA sound/usb/mixer.c:1149 set resolution quirk: cval->res = 384
> 
> Maybe the pro 9000 has been forgotten in the patch?

The patch only addressed 3 models given that at the time only 3 had known issues.  An upstream fix is being worked on that might contain more models.
Comment 13 Stuart R. DeGraaf 2012-01-03 20:26:18 EST
I'm running kernel 3.1.6-1.fc16.x86_64 and have the same problem with a Logitech USB webcam microphone not working.

Bus 001 Device 005: ID 046d:09a5 Logitech, Inc. Quickcam 3000 For Business

/var/log/messages shows, among other things:

Jan  2 09:12:24 seagull pulseaudio[10533]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id="1" name="usb-046d_09a5_2665FA20-02-U0x46d0x9a5" card_name="alsa_card.usb-046d_09a5_2665FA20-02-U0x46d0x9a5" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1""): initialization failed.

Jan  2 09:20:30 seagull pulseaudio[1592]: alsa-source.c: Failed to set hardware parameters: Connection timed out

dmesg shows, among other things:

[49376.474263] ALSA sound/usb/clock.c:227 2:3:1: cannot set freq 16000 to ep 0x86

For what it's worth, I'm using XFCE4 and pavucontrol/pnmixer suggests that the microphone works - the signal fluctuates with my voice - yet neither arecord nor skype shows any signs of acoustic life. Cold-plugging seems not to work; I either have to rmmod/modprobe ucvideo or unplug/plug the webcam to even get this far.

What to do?

This is just one of many odd/frustrating things I'm seeing with Fedora 16. Other major ones that may be related to the above(?) include: pnmixer only shows up in the XFCE notification tray roughly half the time; very erratic login/logout times (ranging from a second to roughly two minutes) that don't seem to correlate with whether or not pnmixer shows up; occasional logins where no graphical content *ever* appears, requiring control-alt-backspace to restart X; NetworkManager periodically dropping both wired and USB wireless network connections.
Comment 14 Stuart R. DeGraaf 2012-01-03 20:36:00 EST
I'm running kernel 3.1.6-1.fc16.x86_64 and have the same problem with a Logitech USB webcam microphone not working.

Bus 001 Device 005: ID 046d:09a5 Logitech, Inc. Quickcam 3000 For Business

/var/log/messages shows, among other things:

Jan  2 09:12:24 seagull pulseaudio[10533]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id="1" name="usb-046d_09a5_2665FA20-02-U0x46d0x9a5" card_name="alsa_card.usb-046d_09a5_2665FA20-02-U0x46d0x9a5" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1""): initialization failed.

Jan  2 09:20:30 seagull pulseaudio[1592]: alsa-source.c: Failed to set hardware parameters: Connection timed out

dmesg shows, among other things:

[49376.474263] ALSA sound/usb/clock.c:227 2:3:1: cannot set freq 16000 to ep 0x86

For what it's worth, I'm using XFCE4 and pavucontrol/pnmixer suggests that the microphone works - the signal fluctuates with my voice - yet neither arecord nor skype shows any signs of acoustic life. Cold-plugging seems not to work; I either have to rmmod/modprobe ucvideo or unplug/plug the webcam to even get this far.

What to do?

This is just one of many odd/frustrating things I'm seeing with Fedora 16. Other major ones that may be related to the above(?) include: pnmixer only shows up in the XFCE notification tray roughly half the time; very erratic login/logout times (ranging from a second to roughly two minutes) that don't seem to correlate with whether or not pnmixer shows up; occasional logins where no graphical content *ever* appears, requiring control-alt-backspace to restart X; NetworkManager periodically dropping both wired and USB wireless network connections.
Comment 15 Luca Cavalli 2012-08-13 05:39:42 EDT
Still present on Fedora 17 with kernel 3.5.1-1.fc17.i686.

Effected Logitech webcam is "QuickCam E 3500".
Comment 16 Charles Slivkoff 2012-08-23 12:24:16 EDT
This continues to be an issue causing various audio problems, including application hangs even when the device is not in-use. 

I am using this device:

046d:09a5 Logitech, Inc. Quickcam 3000 For Business

Please reopen this.
Comment 17 Ryan K 2012-08-26 20:17:51 EDT
Also affects me with a Logitech C260 webcam

Fedora 17 x64, kernel 3.5.2-3
Comment 18 Ryan K 2012-08-26 22:15:13 EDT
Here is an example of the error messages generated during resume from suspend:

[33240.070635] uhci_hcd 0000:00:1d.1: setting latency timer to 64
[33240.070645] snd_hda_intel 0000:00:1b.0: irq 49 for MSI/MSI-X
[33240.070649] usb usb6: root hub lost power or was reset
--
[33241.828387] PM: resume of devices complete after 1759.039 msecs
[33242.828176] ALSA sound/usb/clock.c:228 6:3:1: cannot set freq 16000 to ep 0x86
[33242.960980] ALSA sound/usb/clock.c:228 6:3:2: cannot set freq 24000 to ep 0x86
[33243.960445] ALSA sound/usb/clock.c:228 6:3:3: cannot set freq 32000 to ep 0x86
[33244.960948] ALSA sound/usb/clock.c:228 6:3:4: cannot set freq 48000 to ep 0x86
[33244.961962] ALSA sound/usb/mixer.c:866 5:2: cannot get min/max values for control 2 (id 5)
[33244.962845] PM: Finishing wakeup.
Comment 19 Eric Faure 2012-09-04 17:06:02 EDT
I'm Also affected by this bug using Logitech, Inc. Webcam C270 (ID 046d:0825)

fedora 17 x64 kernel 3.5.3-1.fc17.x86_64

messages:
[   10.417138] ALSA sound/usb/clock.c:228 2:3:1: cannot set freq 16000 to ep 0x86
[   11.417169] ALSA sound/usb/clock.c:228 2:3:2: cannot set freq 24000 to ep 0x86
[   12.417327] ALSA sound/usb/clock.c:228 2:3:3: cannot set freq 32000 to ep 0x86
[   13.417107] ALSA sound/usb/clock.c:228 2:3:4: cannot set freq 48000 to ep 0x86

I guess this bug exists since fedora 12 (Bug 583168,663583) and has never been fixed.

Do we have to open another ticket again for fedora 17?
Comment 20 Josh Boyer 2012-09-05 08:36:53 EDT
(In reply to comment #19)
> Do we have to open another ticket again for fedora 17?

I'll try and come up with a scratch build kernel to test later today.  So far I have the following device IDs to add:


C270 (ID 046d:0825)
Quickcam 3000 For Business (ID 046d:09a5)

I'd need the USB ID for

QuickCam E 3500
C260
Comment 21 Luca Cavalli 2012-09-05 08:40:06 EDT
(In reply to comment #20)
> [...]
> 
> I'd need the USB ID for
> 
> QuickCam E 3500
> C260

Hi, the id of QuickCam E 3500 is 046d:09a4
Comment 22 Ryan K 2012-09-05 20:13:35 EDT
The id for the C260 is 046d:081a
Comment 23 Ryan K 2012-09-05 20:20:38 EDT
The id for the C260 is 046d:081a
Comment 24 Josh Boyer 2012-09-07 11:40:59 EDT
Actually, looking at the code all of these IDs already have the quirk added in the 3.5 kernel, and in 3.6 the entire class of logitech webcams is added.

If you're still hearing chipmunk sound after a resume on these kernel levels, it is likely due to a different problem.  Please open a new bug for this.
Comment 25 Charles Slivkoff 2012-09-07 15:09:59 EDT
I believe this is more than just suspend/resume issue. I've never had audible problems, but do get audio lock-ups (pulseaudio becomes non-responsive) along with the "cannot set freq" messages. Unplugging the webcam seems to get things working again.
Comment 26 Luca Cavalli 2012-09-09 12:40:28 EDT
Also for me the problem is not related to suspend/resume. I have this bug on my desktop computer and unplugging/replugging the webcam fixes it.
Comment 27 djcb 2012-09-09 16:47:56 EDT
(In reply to comment #24)
> Actually, looking at the code all of these IDs already have the quirk added
> in the 3.5 kernel, and in 3.6 the entire class of logitech webcams is added.
> 
> If you're still hearing chipmunk sound after a resume on these kernel
> levels, it is likely due to a different problem.  Please open a new bug for
> this.

I've created a new bug #855671 for this.

Note You need to log in before you can comment on or make changes to this bug.