Bug 729315 - kernel 2.6.40-4.fc15.i686.PAE crashes on boot
Summary: kernel 2.6.40-4.fc15.i686.PAE crashes on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 739310 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 13:47 UTC by josip@icase.edu
Modified: 2012-04-11 16:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-11 16:52:42 UTC


Attachments (Terms of Use)
Photo of crash on startup (1.66 MB, image/jpeg)
2011-08-10 09:09 UTC, Eddie Lania
no flags Details

Description josip@icase.edu 2011-08-09 13:47:19 UTC
Description of problem:
Upgrading to 2.6.40 causes crashes in the earliest stages of booting.  On the same system, kernel 2.6.38-35 works fine.


Version-Release number of selected component (if applicable):
kernel 2.6.40-4.fc15.i686.PAE


How reproducible:
Upgrade to kernel 2.6.40-4, try to boot, see crash

Steps to Reproduce:
1. Upgrade F15 with kernel-PAE-2.6.40-4.fc15.i686
2. Boot new kernel
3. Crash
  
Actual results:
Crash

Expected results:
Normal boot


Additional info:
Crash happens in modes 1, 3, and 5.  Sometimes the kernel complains about dereferencing NULL pointer but sometimes longer traceback obliterates previous messages on screen.  Supposedly, bugs relevant to 2.6.40-3 and earlier versions are fixed in 2.6.40-4, but it crashes anyway, so this may be a new kernel bug.

Comment 1 Eddie Lania 2011-08-10 09:09:25 UTC
Created attachment 517551 [details]
Photo of crash on startup

Comment 2 Josh Boyer 2012-01-06 15:08:41 UTC
Matthew Garrett pointed me at a patch for a regression in ACPI yesterday.  I've started a scratch build with this patch applied.  Could those with an impacted machine please try this kernel when it finishes building and let us know the results?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3624930

Comment 3 Josh Boyer 2012-01-06 16:05:19 UTC
My apologies, I pasted the wrong link to the scratch build.  This is the one that should be tested:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3625177

Comment 4 Dave Jones 2012-04-11 16:51:57 UTC
*** Bug 739310 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.