Bug 739310 - kernel 2.6.40.4-5.fc15.i686.PAE crashes on boot
Summary: kernel 2.6.40.4-5.fc15.i686.PAE crashes on boot
Keywords:
Status: CLOSED DUPLICATE of bug 729315
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 13:03 UTC by josip@icase.edu
Modified: 2012-04-11 16:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-11 16:51:57 UTC


Attachments (Terms of Use)
Photo of crash screen (164.28 KB, image/jpeg)
2011-09-17 13:07 UTC, josip@icase.edu
no flags Details

Description josip@icase.edu 2011-09-17 13:03:49 UTC
Description of problem:
Crash on boot after 0.8 seconds

Version-Release number of selected component (if applicable):
kernel 2.6.40.4-5.fc15.i686.PAE

How reproducible:
Upgrade to this kernel, reboot

Steps to Reproduce:
1.Upgrade
2.Reboot
3.Crash
  
Actual results:
Crash

Expected results:
No crash

Additional info:
The same server works fine with kernels 2.6.38 and older.  It runs Pentium 4 at 2.8 GHz on an Intel D865PERL motherboard.  Photo of the crash screen is attached, since data can't be captured otherwise.  See also bug 729315 about crashes using kernel 2.6.40-4.fc15.i686.PAE

Comment 1 josip@icase.edu 2011-09-17 13:07:48 UTC
Created attachment 523709 [details]
Photo of crash screen

Photo of crash screen 0.8 seconds into the boot process.

Comment 2 Chuck Ebbert 2011-09-19 18:05:19 UTC
acpi_processor_power_init() calls acpi_processor_get_power_info(), which eventually jumps to 0xffffff00

Can you try to get more information?
1. Install kernel-debug package
2. Boot with acpi.debug_layer=0x20000000 acpi.debug_level=0x7
3. See if any additional messages print before the oops

Comment 3 lacibacsi 2011-09-20 09:21:00 UTC
I've got the same problem on an Intel S875WP1 motherboard + Pentium 4 2,8 GHz.

Comment 4 josip@icase.edu 2011-09-30 14:40:58 UTC
I tried both kernel-PAEdebug and kernel-debug.   With kernel-PAEdebug, too much output scrolls off the screen to give me anything useful.  With kernel-debug, the kernel crash (about 3 seconds into the boot process) seems to occur in acpi_processor_power_init().  Traceback shows acpi_processor_add, acpi_device_probe, acpi_bus_register_device, acpi_processor_init, and acpi_pci_slot_init, interspersed with non-acpi functions.

This is a Pentium 4 2.8GHz SINGLE core processor with hyper threading only.  Is it possible that acpi_processor_power_init is getting confused about the core count?

Comment 5 Josh Boyer 2011-09-30 16:36:37 UTC
The backtrace in comment #1 looks very similar to the backtrace in the 'test 3' attachment in bug 730007.  Both machines have P4 CPUs.

Comment 6 josip@icase.edu 2011-11-29 07:07:00 UTC
I've just upgraded to Fedora 16, using kernel 3.1.2-1, and while it also crashed on boot in its default setting, using "acpi=off" allows it to work. 

The same server works fine with kernels 2.6.38 and older.  It runs Pentium 4 at
2.8 GHz on an Intel D865PERL motherboard.

Again, something broke after 2.6.28, presumably related to ACPI handling on genuine Intel P4 systems, and it is still broken in 3.1.2, but at least I found a workaround: "acpi=off".

Comment 7 Josh Boyer 2012-01-06 15:08:52 UTC
Matthew Garrett pointed me at a patch for a regression in ACPI yesterday.  I've started a scratch build with this patch applied.  Could those with an impacted machine please try this kernel when it finishes building and let us know the results?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3624930

Comment 8 Josh Boyer 2012-01-06 16:05:21 UTC
My apologies, I pasted the wrong link to the scratch build.  This is the one that should be tested:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3625177

Comment 9 Dave Jones 2012-04-11 16:51:57 UTC

*** This bug has been marked as a duplicate of bug 729315 ***


Note You need to log in before you can comment on or make changes to this bug.