Bug 729364 - Non-admin users cannot access pulp
Summary: Non-admin users cannot access pulp
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL:
Whiteboard:
: 738498 (view as bug list)
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-09 17:01 UTC by Justin Sherrill
Modified: 2013-08-16 18:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:51:56 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2011-08-09 17:01:57 UTC
Description of problem:

we added a user-less authentication to candlepin, but pulp has no such thing.  We either need to add something similar to pulp or create users in pulp.



Steps to Reproduce:
1.  Create another user in katello
2.  Give that user permissions to access a page that touches repos (like sync management)
3.  Try to login and go to that page
  
Actual results:

ISE  (Permission denied from pulp)


Expected results:
Pulp communication works fine

Comment 1 Jeff Weiss 2011-09-15 19:07:03 UTC
*** Bug 738498 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Weiss 2011-09-19 17:01:21 UTC
Adding testblocker keyword - this is blocking quite a few automated tests.

Automation can't use admin throughout because it gets notices from other sessions (auto runs 3 concurrent sessions to execute quickly).  So it now uses 3 different Administrator role users.

Comment 3 Jeff Weiss 2011-09-30 15:50:00 UTC
I've been told this was fixed - marking MODIFIED (don't know what commit(s)) so that automation will retry.  Will go back to NEW or VERIFIED depending on outcome.

Comment 4 Jeff Weiss 2011-09-30 15:57:54 UTC
Verified, katello-0.1.85-1.git.70.844626c.fc14.noarch

Comment 8 Mike McCune 2013-08-16 18:06:19 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.