Bug 738498 - Administrator users other than "admin" cannot access Sync Management tab
Summary: Administrator users other than "admin" cannot access Sync Management tab
Keywords:
Status: CLOSED DUPLICATE of bug 729364
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jason E. Rist
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 02:02 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 19:07:03 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-09-15 02:02:56 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.81-1.git.17.3b13137.fc14.noarch

How reproducible:
always

Steps to Reproduce:
1. As admin, create a user "admin1", give him the role "Administrator"
2. Log in as admin1
3. Go to the "Content Management"/"Sync Management" tab
  
Actual results:
500 Error page, and error notification:
'Pulp::Repository: 401 Unauthorized "Invalid OAuth Credentials" (GET /pulp/api/repositories/?groupid=env%3A1)'

Expected results:
sync tab contents displayed

Additional info:
Started GET "/katello//sync_management/index" for 10.11.10.45 at Wed Sep 14 21:55:06 -0400 2011
  Processing by SyncManagementController#index as HTML
Completed   in 123ms
Rendering 500:Pulp::Repository: 401 Unauthorized "Invalid OAuth Credentials" (GET /pulp/api/repositories/?groupid=env%3A1)
Rendered layouts/_ajax_notices.haml (4.7ms)
Rendered layouts/_notification.haml (0.4ms)
Rendered layouts/_header.haml (7.0ms)
Rendered layouts/_footer.haml (0.7ms)
Rendered common/_common_i18n.html.haml (0.3ms)
Rendered common/500.html.haml within layouts/katello_error (20.0ms)

2011-09-14 21:55:06,163 5118:140054856955648: pulp.server.auth.authentication:ERROR: authentication:108 User [admin1] specified in certificate was not found in the system

Comment 1 Jeff Weiss 2011-09-15 19:07:03 UTC

*** This bug has been marked as a duplicate of bug 729364 ***


Note You need to log in before you can comment on or make changes to this bug.