Bug 729528 - Unable to configure events in reporter to forward in anaconda for F-16-Alpha-RC3
Unable to configure events in reporter to forward in anaconda for F-16-Alpha-RC3
Status: CLOSED DUPLICATE of bug 729537
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
16
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-08-10 00:01 EDT by He Rui
Modified: 2015-02-01 17:54 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-12 14:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Reporter_window.png (51.84 KB, image/png)
2011-08-10 00:01 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2011-08-10 00:01:03 EDT
Created attachment 517514 [details]
Reporter_window.png

Description of problem:
Triggered an exception on anaconda, tried to save it but it didn't allow to edit or configure the events though the window prompted, so it can't be forwarded to continue the bug report.

Version-Release number of selected component (if applicable):
anaconda 16.14.3 of Alpha RC3

How reproducible:
100%

Steps to Reproduce:
1. Trigger an expection
2. Click 'save'
3. Click 'configure events' and try to edit any word
  
Actual results:
Can't save traceback
Comment 1 He Rui 2011-08-10 02:49:46 EDT
The steps to trigger a bug which hasn't been fixed is:

1. Boot with ks=http://rhe.fedorapeople.org/install/partition.cfg
2. Select 'Create Custom layout' and click 'next'
Comment 2 Jiri Moskovcak 2011-08-10 10:01:51 EDT
seems like there are no reporters on the anaconda image...
Comment 3 Tim Flink 2011-08-10 17:22:56 EDT
Discussed in the 2011-08-10 Fedora 16 go/no-go meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

The installer must be able to report failures to Bugzilla, with appropriate information included.

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 4 Timothy Davis 2011-08-11 08:26:23 EDT
My internet connection is through a wireless adapter (Belkin USB) and networking doesn't work until after the installation is completed. Is there some way to get networking up so that errors can be reported. This may sound like a different issue.
Comment 5 Jiri Moskovcak 2011-08-11 09:00:58 EDT
(In reply to comment #4)
> My internet connection is through a wireless adapter (Belkin USB) and
> networking doesn't work until after the installation is completed. Is there
> some way to get networking up so that errors can be reported. This may sound
> like a different issue.

yes, different issue, you can still use an usb key and copy /tmp/anaconda-tb-* to it and attach it to your bz report later...
Comment 6 Tim Flink 2011-08-11 13:13:10 EDT
Has there been any progress on figuring what needs to be done in order to fix this? The alpha has already slipped a week and this was accepted as a blocker.
Comment 7 Jiri Moskovcak 2011-08-11 13:37:54 EDT
we need to make sure this packages are included:

libreport-python
libreport
libreport-gtk
libreport-newt                  (required by rhbz#729537)
libreport-plugin-reportuploader (uplaods to ftp, scp, whatever curl can handle)
libreport-plugin-bugzilla


I'm not sure how the image building tool handles dependencies, so I wrote the full list. This bug is caused by missing libreport-plugin-* from the image.
Comment 8 Mads Kiilerich 2011-08-11 13:56:32 EDT
For installation from Live CD the dependencies should be handled by the abrt-desktop meta package which is in comps group gnome-desktop which is installed by fedora-live-desktop.ks.

I guess abrt-desktop should be updated to require all the dependencies listed in comment 7.
Comment 9 Adam Williamson 2011-08-12 13:49:03 EDT
Jiri: when you say 'include', we're talking about in the set of packages *available as part of the installation environment*, right? Not just 'on the DVD'? so this is, what, lorax stuff?
Comment 10 Jiri Moskovcak 2011-08-12 14:06:41 EDT

*** This bug has been marked as a duplicate of bug 729537 ***

Note You need to log in before you can comment on or make changes to this bug.