This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 729537 - Anaconda cannot report crashes in text mode in F16 Alpha RC3 due to missing report-cli
Anaconda cannot report crashes in text mode in F16 Alpha RC3 due to missing r...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 729528 (view as bug list)
Depends On:
Blocks: F16Alpha/F16AlphaBlocker 729566
  Show dependency treegraph
 
Reported: 2011-08-10 02:02 EDT by Adam Williamson
Modified: 2013-07-04 08:58 EDT (History)
10 users (show)

See Also:
Fixed In Version: lorax-16.4.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 729566 (view as bug list)
Environment:
Last Closed: 2011-08-18 18:23:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-08-10 02:02:39 EDT
Splitting off the bug Andre Robatino reported in https://bugzilla.redhat.com/show_bug.cgi?id=692433#c22 :

Anaconda can't report any traces in Fedora 16 Alpha RC3 if it's running in text mode, simply because the report-cli executable it tries to run (Andre sees "Can't execute report-cli: No such file or directory") is missing. This is part of the libreport-cli package. By switching to a console in the installer I can see that report-gtk and report-newt are available, but not report-cli.
Comment 1 Adam Williamson 2011-08-10 02:03:34 EDT
Proposing as Alpha blocker under criterion "The installer must be able to report failures to Bugzilla, with appropriate information included". This will require judgement as this bug is conditional: it's specific to text mode installs.
Comment 2 Jiri Moskovcak 2011-08-10 07:55:32 EDT
I'm on it, will do my best to fix it later today, but my more realistic guess is Friday.
Comment 3 Jiri Moskovcak 2011-08-10 10:56:10 EDT
We need to add:

libreport-gtk
libreport-python
libreport-plugin-bugzilla
libreport-plugin-reportuploader
libreport-newt

+ it's deps which should be pulled automatically
Comment 4 Adam Williamson 2011-08-10 11:58:08 EDT
are you sure that's right? those look like things that are already in there.
Comment 5 Jiri Moskovcak 2011-08-10 14:49:55 EDT
(In reply to comment #4)
> are you sure that's right? those look like things that are already in there.

- yes, it's those packages + a fix to run newt UI instead of cmdline, I have it ready, but still fighting with creating my own anaconda img to test it (it's not as simple as it used to be when there was a separate stage2...)
Comment 6 Tim Flink 2011-08-10 17:25:40 EDT
Discussed in the 2011-08-10 Fedora 16 go/no-go meeting. Accepted as a Fedora 16 alpha blocker as it violates the following alpha release criterion [1]:

The installer must be able to report failures to Bugzilla, with appropriate information included.

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 7 Jiri Moskovcak 2011-08-12 14:06:41 EDT
*** Bug 729528 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2011-08-12 14:59:21 EDT
lorax-16.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4-3.fc16
Comment 9 Tim Flink 2011-08-12 15:13:42 EDT
I hit this when I was testing for bug 729528 but when I hacked lorax to include the builds listed there, I was able to start reporting anaconda bugs to bugzilla.

However, I got the following error when I tried to actually send it to bz:

fatal: XML-RPC(-504): libcurl failed to execute the HTTP POST transaction, explaining: Problem with the SSL CA cert (path? access rights?)
(exited with 1)

I couldn't find any more details in the logs and this happened during two installation attempts (purposely hitting a known anaconda issue to make it crash).
Comment 10 Martin Gracik 2011-08-12 15:30:39 EDT
Lorax is removing all /etc/ssl/* files from the ca-certificates package, so if libcurl needs them, this may be the problem.
Comment 11 Adam Williamson 2011-08-12 15:31:21 EDT
Is the lorax update alone sufficient or is a libreport update also necessary, as discussed in the blocker meeting? If a libreport update is also needed, please bundle the updates together, to reduce the chances of us incorrectly pulling only a partial fix for RC4. thanks!
Comment 12 Fedora Update System 2011-08-12 16:36:14 EDT
Package lorax-16.4-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-16.4-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lorax-16.4-3.fc16
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-08-12 16:59:47 EDT
libreport-2.0.5-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreport-2.0.5-5.fc16
Comment 14 Tim Flink 2011-08-12 18:56:24 EDT
(In reply to comment #9)
> I hit this when I was testing for bug 729528 but when I hacked lorax to include
> the builds listed there, I was able to start reporting anaconda bugs to
> bugzilla.
> 
> However, I got the following error when I tried to actually send it to bz:
> 
> fatal: XML-RPC(-504): libcurl failed to execute the HTTP POST transaction,
> explaining: Problem with the SSL CA cert (path? access rights?)
> (exited with 1)

Since this isn't directly related to the libreport issue, I filed it as bug 730438
Comment 15 Fedora Update System 2011-08-15 04:39:16 EDT
lorax-16.4.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.1-1.fc16
Comment 16 Fedora Update System 2011-08-16 09:48:35 EDT
libreport-2.0.5-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreport-2.0.5-6.fc16
Comment 17 Adam Williamson 2011-08-17 01:38:52 EDT
tflink, did you confirm this is okay in RC5?
Comment 18 He Rui 2011-08-17 02:33:27 EDT
Saving traceback in text mode works fine for me in RC5. it can file new bug/detect duplicate now.
Comment 19 Adam Williamson 2011-08-17 04:31:47 EDT
thanks, setting VERIFIED.
Comment 20 Fedora Update System 2011-08-18 18:23:30 EDT
libreport-2.0.5-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2011-08-25 05:38:21 EDT
lorax-16.4.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.2-1.fc16
Comment 22 Fedora Update System 2011-08-30 22:39:15 EDT
lorax-16.4.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.