Bug 729599 - PartitionException: msdos disk labels do not support partition names.
Summary: PartitionException: msdos disk labels do not support partition names.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH
Keywords:
: 729927 (view as bug list)
Depends On:
Blocks: F16Alpha-accepted, F16AlphaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-08-10 10:03 UTC by Joachim Backes
Modified: 2011-08-18 22:24 UTC (History)
8 users (show)

Fixed In Version: anaconda-16.14.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-18 22:24:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped tar file containing: anaconda traceback, anaconda.log and abrt.log (141.89 KB, application/x-gzip)
2011-08-10 10:03 UTC, Joachim Backes
no flags Details
traceback (1.28 MB, text/plain)
2011-08-10 14:04 UTC, Chris Lumens
no flags Details
anaconda.log (11.09 KB, text/x-log)
2011-08-10 16:25 UTC, Joachim Backes
no flags Details
ifcfg.log (2.29 KB, text/x-log)
2011-08-10 16:26 UTC, Joachim Backes
no flags Details
programlog (151.87 KB, text/x-log)
2011-08-10 16:27 UTC, Joachim Backes
no flags Details
storage.log (323.63 KB, text/x-log)
2011-08-10 16:28 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2011-08-10 10:03:18 UTC
Created attachment 517561 [details]
gzipped tar file containing: anaconda traceback, anaconda.log and abrt.log

Description of problem:

I booted the F16/alpha/rc2/live cd (x86_64, selinux=0) and tried to "install to harddisk". Selecting "custom install" to an existing extended ext4 partition which should to be overwritten: crash!

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lumens 2011-08-10 14:03:32 UTC
When you hit a traceback, there's really no need to do anything besides attach /tmp/anaconda-tb-* as a text file to this bug.  By attaching things as tarballs, you are making it more difficult for us to search attachments in the future and that's something I do pretty much all the time.

Comment 2 Chris Lumens 2011-08-10 14:04:27 UTC
Created attachment 517617 [details]
traceback

anaconda 16.14.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 418, in doIt
    ped_partition.set_name(dev.format.name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
    self.anaconda.dispatch.go_forward()
PartitionException: msdos disk labels do not support partition names.

Comment 3 Joachim Backes 2011-08-10 16:25:19 UTC
Created attachment 517649 [details]
anaconda.log

Comment 4 Joachim Backes 2011-08-10 16:26:29 UTC
Created attachment 517650 [details]
ifcfg.log

Comment 5 Joachim Backes 2011-08-10 16:27:09 UTC
Created attachment 517651 [details]
programlog

Comment 6 Joachim Backes 2011-08-10 16:28:14 UTC
Created attachment 517652 [details]
storage.log

Comment 7 Joachim Backes 2011-08-10 16:29:54 UTC
same problem with the f16-alpha-rc3-install (not live!!) dvd. See attachments anaconda.log, ifcfg.log, programlog, storage.log

Comment 8 Joachim Backes 2011-08-11 08:40:38 UTC
(In reply to comment #1)
> When you hit a traceback, there's really no need to do anything besides attach
> /tmp/anaconda-tb-* as a text file to this bug.  By attaching things as
> tarballs, you are making it more difficult for us to search attachments in the
> future and that's something I do pretty much all the time.

I started a second test, now with F16/RC3 install DVD (not live!), using the same extended partition (ext4) which I formatedd outside anaconda in F15. I declared it as "/"-partition. Then proceeding (next), anaconda works a little bit, then crashes.

I posted some files to

http://www-user.rhrk.uni-kl.de/~backes/UL/anaconda.log
http://www-user.rhrk.uni-kl.de/~backes/UL/program.log
http://www-user.rhrk.uni-kl.de/~backes/UL/storage.state
http://www-user.rhrk.uni-kl.de/~backes/UL/storage.log
http://www-user.rhrk.uni-kl.de/~backes/UL/anaconda-tb-zQc0f2
http://www-user.rhrk.uni-kl.de/~backes/UL/syslog


You can download them from there.

Kind regards

Joachim Backes

Comment 9 Martin Sivák 2011-08-11 11:21:38 UTC
*** Bug 729927 has been marked as a duplicate of this bug. ***

Comment 10 Jens Petersen 2011-08-12 01:08:49 UTC
Just for the record (workaround): I manage to install Live anyway 
by "tricking" anaconda into continuing the install "somehow"
(something like pressing Debug and then quickly Next/Continue
- sorry I don't remember quite remember): perhaps it is only
possible from the Live desktop?

Comment 11 Tim Flink 2011-08-12 18:50:23 UTC
Discussed in the 2011-08-12 blocker review meeting. Since a custom layout was used for this bug, it doesn't hit any of the alpha blocker criteria. However, it does hit the following Fedora 16 final release criteria [1]:

The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above.

Re-proposing as a final blocker.

[1] https://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria

Comment 12 Gianluca Sforna 2011-08-12 21:15:59 UTC
As an additional point of data, I hit this bug on an upgrade where I wanted to keep /home, so it was not really a "custom" partitioning (in the sense that the layout is the same the installer would do if I'd let it "Remove all linux partitions"

Sadly, in the end I had to install F15 on that PC but hoped to try it again for Alpha. Looks like I'll need to wait for final

Comment 13 Brian Lane 2011-08-12 21:25:15 UTC
People will hit this when /boot is on a disk with a msdos label, eg. when upgrading. The fix it on master, it was a matter of making sure we check for the PARTITION_NAME support before writing the partition label.

Comment 14 Tim Flink 2011-08-12 21:42:38 UTC
(In reply to comment #13)
> People will hit this when /boot is on a disk with a msdos label, eg. when
> upgrading. The fix it on master, it was a matter of making sure we check for
> the PARTITION_NAME support before writing the partition label.

Upgrading is not covered by the alpha release criteria [1] but is covered by the beta release criteria [2] as:

The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria.

If a user would hit this by using one of the default partitioning options on a fresh install, it could be considered an alpha blocker:

The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled.

I suppose that alpha NTH would also be possible if msdos disk labels are common and a tested fix was available.

[1] http://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
[2] http://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria

Comment 15 Tim Flink 2011-08-12 21:58:52 UTC
After talking with Brian in IRC, it turns out that any install on a disk with MSDOS disk labels and not being completely wiped would hit this.

Re-proposing as Fedora 16 NTH.

I'm +1 NTH on this since the impact is greater than we thought at first.

Comment 16 Adam Williamson 2011-08-12 22:02:25 UTC
+1 NTH, that's a nasty impact which affects quite a range of scenarios.

Comment 17 Gianluca Sforna 2011-08-12 22:37:23 UTC
Thank you very much.

I take this chance to thank all the anaconda developers and QA team for the amazing amount of work poured into each and every Fedora release; I'm proud to be part of this community

Comment 18 Fedora Update System 2011-08-15 16:55:13 UTC
anaconda-16.14.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.5-1.fc16

Comment 19 Adam Williamson 2011-08-15 17:11:16 UTC
Discussed at the weekly QA meeting of 2011-08-15 (with anaconda team and releng in attendance). Accepted as NTH due to potential impact on clean installs (I could not reproduce in an artificial test, but there's someone on test@ who may be hitting this).

Comment 20 Fedora Update System 2011-08-15 20:23:23 UTC
Package anaconda-16.14.5-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.14.5-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.14.5-1.fc16
then log in and leave karma (feedback).

Comment 21 Jens Petersen 2011-08-16 03:59:00 UTC
Live install of Alpha RC4 looks good to me now.

Comment 22 Joachim Backes 2011-08-16 08:33:15 UTC
I can confirm that anaconda-16.14.5-1.fc16 installs F16 from the Alpha-RC4-live if "installing to harddisk". But the bootloader could not be written (I will open a new BZ for that), so this F16 is not bootable.

Comment 23 Gianluca Sforna 2011-08-16 08:53:22 UTC
This time netboot install got past this issue, well done.

I hit another roadblock because it now says it can't mount my existing /home LV; of course that's for another BZ

Comment 24 Fedora Update System 2011-08-16 20:14:24 UTC
anaconda-16.14.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.14.6-1.fc16

Comment 25 Fedora Update System 2011-08-18 22:23:57 UTC
anaconda-16.14.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.