Bug 729600 - Cant install without network presence of dvd rc3. ( came across the same issue with F15 )
Cant install without network presence of dvd rc3. ( came across the same issu...
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Bokoc
Ruediger Landmann
RejectedBlocker, RejectedNTH
:
: 730488 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 06:22 EDT by Jóhann B. Guðmundsson
Modified: 2013-07-31 10:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 10:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Picture where this is triggered (3.23 MB, image/jpeg)
2011-08-10 06:22 EDT, Jóhann B. Guðmundsson
no flags Details
Software selection screen after I have hooked the hw to network (3.00 MB, image/jpeg)
2011-08-10 06:58 EDT, Jóhann B. Guðmundsson
no flags Details
Anaconda log (11.10 KB, text/plain)
2011-08-10 10:28 EDT, Jóhann B. Guðmundsson
no flags Details
syslog (98.46 KB, text/plain)
2011-08-10 10:29 EDT, Jóhann B. Guðmundsson
no flags Details
Yum Log (988 bytes, text/plain)
2011-08-10 10:29 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-08-10 06:22:28 EDT
Created attachment 517564 [details]
Picture where this is triggered

Description of problem:

See picture this is a next next installation test on hp pavilion dm1

Note that after hitting cancel several times on the network interface it errors out with 

No Network Available 

Some of the software repositories require networking but there was an error enabling the network on your system. 

[exit installer] < wtf

double wtf ^^^ I did not select any software repositories heck I have not even reach the software selection screen yet!!! 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-08-10 06:36:43 EDT
Prosed blocker user unable to install to hard drive without network presence is a serious bug in the installer
Comment 2 Jóhann B. Guðmundsson 2011-08-10 06:58:14 EDT
Created attachment 517576 [details]
Software selection screen after I have hooked the hw to network

Default selected repos when I have hooked up a network connection arent we missing local media here ( in this case usb ) ?
Comment 3 Chris Lumens 2011-08-10 10:10:39 EDT
Please attach /tmp/anaconda.log, /tmp/syslog, and /tmp/yum.log as individual attachments to this bug report.
Comment 4 Jóhann B. Guðmundsson 2011-08-10 10:28:46 EDT
Created attachment 517628 [details]
Anaconda log
Comment 5 Jóhann B. Guðmundsson 2011-08-10 10:29:13 EDT
Created attachment 517629 [details]
syslog
Comment 6 Jóhann B. Guðmundsson 2011-08-10 10:29:37 EDT
Created attachment 517631 [details]
Yum Log
Comment 7 Jóhann B. Guðmundsson 2011-08-10 15:15:16 EDT
This bug breaks the following Alpha criteria.. 

The installer must be able to complete an installation using the text, graphical and VNC installation interfaces 

( The absence of network prevents the installer from proceeding to install this locally  )  

The installer must be able to complete package installation with the default package set for each supported installation method

( The absence of network prevents the installer from proceeding  The absence of network prevents the installer from proceeding to install this locally )  

The installer must be able to complete an installation using any locally connected storage interface (e.g. PATA, SATA, SCSI etc...) with the default file system

( The absence of network prevents the installer from proceeding  The absence of network prevents the installer from proceeding to install this locally )  

The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled 

( The absence of network prevents the installer from proceeding  The absence of network prevents the installer from proceeding to install this locally )  

On top of that the installer wipes the hard drive of any previous installation before error-ing out which leaves the end user stuck with no OS installed and no means to install it.
Comment 8 Chris Lumens 2011-08-10 15:28:40 EDT
14:19:54,247 ERR loader: got to findInstallCD without a CD device

Also, I don't see any mention of any sr* devices in your syslog.  Is this something like a USB CD drive?
Comment 9 Jóhann B. Guðmundsson 2011-08-10 15:30:17 EDT
install on bare metal, with dvd iso dd'ed to USB
Comment 10 Jóhann B. Guðmundsson 2011-08-10 15:30:34 EDT
4gb Stick
Comment 11 Jóhann B. Guðmundsson 2011-08-10 15:36:11 EDT
If you want to reproduce this get a 4GB ( or larger ) stick and dd the dvd onto it and proceed with install without network being present.
Comment 12 Chris Lumens 2011-08-10 15:37:21 EDT
anaconda doesn't have any code to automatically detect USB devices like it does CD/DVD.  You either need to pass method= or askmethod to specify that you want to install from that kind of device.

In addition, I don't believe this is covered under the alpha release criteria.  We only test the following:

4. The installer must boot (if appropriate) and run on all primary architectures from default live image, DVD, and boot.iso install media.
Comment 13 Jóhann B. Guðmundsson 2011-08-10 15:56:45 EDT
(In reply to comment #12)
> anaconda doesn't have any code to automatically detect USB devices like it does
> CD/DVD.  You either need to pass method= or askmethod to specify that you want
> to install from that kind of device.
> 
> In addition, I don't believe this is covered under the alpha release criteria. 
> We only test the following:

By we you mean? 

I have always tested on bare metal instead of vm like most of the Red Hat team does these days.. 

> 
> 4. The installer must boot (if appropriate) and run on all primary
> architectures from default live image, DVD, and boot.iso install media.

? 

There is no mentioned that this has to be optical media this could just as well be external media like usb or external hard drive in fact all modern laptops/notebooks/tablet pc come without an optical drive et all. 

And on top of that we have been promoting the use of usb for ages heck even the Desktop team has wanted to drop the cd sized image and move to a larger image which would fit a thumb drive.  

This clearly breaks the following criteria.. 

The installer must be able to complete an installation using the text,
graphical and VNC installation interfaces 

The installer must be able to complete package installation with the default
package set for each supported installation method

The installer must be able to complete an installation using any locally
connected storage interface (e.g. PATA, SATA, SCSI etc...) with the default
file system

The installer must be able to complete an installation using the entire disk,
existing free space, or existing Linux partitions methods, with or without
encryption or LVM enabled
Comment 14 Jesse Keating 2011-08-10 16:53:28 EDT
The use of dd'ing to USB media was not in mind when the release criteria was created/modified.  Particularly for Alpha.  DDing iso media is relatively new, making use of isohybrid on specific isos.

What you have here is not so much a bug as intended behavior, that is intended when the installer cannot locate local install media.  It will by default use the remote repositories, saving users a step.  It is as if you booted with boot.iso rather than the whole media.

Currently Anaconda does not support booting USB media in the way you describe, regardless of any interpretation of the release criteria.  This current bug report is barely a bug (more of a documentation bug really), let alone a blocker.
Comment 15 Chris Lumens 2011-08-10 16:56:35 EDT
> > 4. The installer must boot (if appropriate) and run on all primary
> > architectures from default live image, DVD, and boot.iso install media.
> 
> ? 
> 
> There is no mentioned that this has to be optical media this could just as well
> be external media like usb or external hard drive in fact all modern
> laptops/notebooks/tablet pc come without an optical drive et all. 

You're reading into this what you want to see.  From the presence of the words "install media", it's clear that the intention is that the install work from actual DVDs/CDs.

> This clearly breaks the following criteria.. 
> 
> The installer must be able to complete an installation using the text,
> graphical and VNC installation interfaces 
> 
> The installer must be able to complete package installation with the default
> package set for each supported installation method
> 
> The installer must be able to complete an installation using any locally
> connected storage interface (e.g. PATA, SATA, SCSI etc...) with the default
> file system
> 
> The installer must be able to complete an installation using the entire disk,
> existing free space, or existing Linux partitions methods, with or without
> encryption or LVM enabled

No, you are taking a failure of your one particular case (which really, is NOTABUG since anaconda has never automatically detected USB installation media like this) and extending it to mean that every criteria you want to fail fails.  The intention behind each of these criteria is clear.  The first covers that those three UIs must work.  The second covers that packages can be pulled from each installation method.  The third covers that partitioning and filesystems work.  The fourth covers that the various parttype mechanisms work.
Comment 16 Jóhann B. Guðmundsson 2011-08-10 17:12:09 EDT
Regardless of the different interpretation we put into the release criteria the ( if the intention was this not to work on usb thumb drives the installer should error out that when it's on one with not supported installation method ) installer wipes the hard drive of any previous installation before error-ing out which leaves the end user stuck with no OS installed and no means to install it that in it self warrants blocking the release until fixed no installer should put novice end user in those shoes...
Comment 17 Chris Lumens 2011-08-10 17:22:09 EDT
No, any problem with packages (repo disappears, you change your mind about wanting to install, bugs, etc.) will necessarily cause you to be in this situation since package installation is after partitioning.  That's how it's been for many releases now and it's not been a blocker.

Note that the only reason the hard drive was wiped of any previous installation was because you chose to do that method of installation.  You just as easily could have chosen to resize and use free space, in which case you would still have your previous install.
Comment 18 Jesse Keating 2011-08-10 17:37:47 EDT
(In reply to comment #16)
> Regardless of the different interpretation we put into the release criteria the
> ( if the intention was this not to work on usb thumb drives the installer
> should error out that when it's on one with not supported installation method )

The installer realized it couldn't find the install directory and prompted you for network, multiple times.  You drove it into the ground.

> installer wipes the hard drive of any previous installation before error-ing
> out which leaves the end user stuck with no OS installed and no means to
> install it that in it self warrants blocking the release until fixed no
> installer should put novice end user in those shoes...

See what clumens wrote.
Comment 19 Tim Flink 2011-08-10 17:58:38 EDT
Discussed in the 2011-08-10 Fedora 16 go/no-go meeting. Rejected as Fedora 16 alpha blocker and NTH because:

Installing from a dd'ed DVD iso is expected to require extra configuration. Documentation should be improved to outline the steps required.
Comment 20 Chris Lumens 2011-08-14 11:43:12 EDT
*** Bug 730488 has been marked as a duplicate of this bug. ***
Comment 21 Karsten Wade 2011-12-13 22:46:35 EST
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!
Comment 22 Jack Reed 2012-03-16 01:48:15 EDT
(In reply to comment #14)
> What you have here is not so much a bug as intended behavior, that is intended
> when the installer cannot locate local install media.  It will by default use
> the remote repositories, saving users a step.  It is as if you booted with
> boot.iso rather than the whole media.
> 
> Currently Anaconda does not support booting USB media in the way you describe,
> regardless of any interpretation of the release criteria.  This current bug
> report is barely a bug (more of a documentation bug really), let alone a
> blocker.

(In reply to comment #12)
> anaconda doesn't have any code to automatically detect USB devices like it does
> CD/DVD.  You either need to pass method= or askmethod to specify that you want
> to install from that kind of device.


I've been using this information to verify the dd instructions due to the numerous bugs lodged against them, and askmethod and repo= do not solve the problem of anaconda looking for a network connection for packages instead of using the USB as the sole installation source.

When I specify linux repo=cdrom:sdb1 or linux repo=hd:sdb1 , anaconda crashes just before it reaches the package selection screen.

dd seems to essentially turn a USB stick into a bootable CD-ROM. As the following link confirms, repo= only works with an ISO image, not an exploded tree:

http://fedoraproject.org/wiki/Anaconda_Boot_Options#repo

So, unless it is somehow possible to specify

linux repo=cdrom:sdb1 

or the requirements for

linux repo=hd:sdb1 

are changed from requiring an .iso file, the only way I can see this approach to network-less USB installation working is by also adding a copy of the .iso file to the USB device after it has been created with dd. This seems redundant though.

This brings me back to Chris's Comment 11 in bug 742672, where he says that livecdtools should be strongly recommended instead. I'll add that to the documentation, but since dd seems so problematic and is not favoured, is it worth retaining the instructions for it?

If it is, I need an accurate way to identify the USB as the installation source, assuming there is one. 

Otherwise, I will specify that a network connection is required for any dd installation.

Any help would be appreciated so I can wrap the docs up in time for beta.
Comment 23 Jack Reed 2012-05-02 23:45:19 EDT
Bug 806166 has resolved this issue for F17. A dd'd USB will no longer prompt for a network connection and does not need a boot prompt.

The procedure has also been updated and verified. See:
http://docs.fedoraproject.org/en-US/Fedora_Draft_Documentation/0.1/html/Installation_Guide/Making_USB_Media-UNIX_Linux-other-dd.html

Note You need to log in before you can comment on or make changes to this bug.