Bug 730488 - Installer does not find packages on USB media
Summary: Installer does not find packages on USB media
Keywords:
Status: CLOSED DUPLICATE of bug 729600
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: i686
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-13 16:22 UTC by Michael Ekstrand
Modified: 2011-08-16 00:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-14 15:43:12 UTC


Attachments (Terms of Use)

Description Michael Ekstrand 2011-08-13 16:22:02 UTC
Description of problem:
When installing from a USB stick containing the DVD image, the installer does not find the packages on the USB stick and falls back to a network install.


Version-Release number of selected component (if applicable):
Whatever is on the F15 install media.

How reproducible:
1 out of 1, but I think always - I peeked at the anaconda source, and it seems to systematically ignore all non-CDROM media.

Steps to Reproduce:
1. Download Fedora 15 DVD (I used i386/i686)
2. Install unetbootin
3. Use unetbootin to put the downloaded ISO on a >=4G USB flash drive
4. Boot flash drive and try to install
  
Actual results:
After partitioning, the installer prompts for network configuration and proceeds with a network install, completely ignoring the 3+GB of packages on the flash drive.

Expected results:
Anaconda locates the package tree just like it does when booting a real DVD, and allows the system to be installed without consulting the network.

Additional info:
I had to use unetbootin because the Fedora LiveUSB creator could not use the DVD image (although the Windows version of it was able to use the netinst image).

Comment 1 Chris Lumens 2011-08-14 15:43:12 UTC

*** This bug has been marked as a duplicate of bug 729600 ***

Comment 2 Brian Lane 2011-08-16 00:02:32 UTC
Note that unetbootin may or may not work -- but livecd-iso-to-disk (from livecd-tools) will create a bootable USB disk from any of our official .iso images including DVD.


Note You need to log in before you can comment on or make changes to this bug.