This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 729688 - expected "Network Error" message is not getting displayed in the GUI
expected "Network Error" message is not getting displayed in the GUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Chris Duryee
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-08-10 10:29 EDT by John Sefler
Modified: 2011-12-06 12:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:23:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error dialog that should state "Network error...." (40.07 KB, image/png)
2011-08-10 10:29 EDT, John Sefler
no flags Details
"Error updating system data" is properly displayed in gui when proxy is bad. (31.35 KB, image/png)
2011-09-12 17:46 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-08-10 10:29:18 EDT
Created attachment 517630 [details]
error dialog that should state "Network error...."

Description of problem:
Problem 1: when rhsm.conf is configured with a bad proxy, most all sm calls will fail.  For example...

[root@jsefler-onprem-62server ~]# subscription-manager facts --update
Network error, unable to connect to server.
 Please see /var/log/rhsm/rhsm.log for more information.
[root@jsefler-onprem-62server ~]# 

^^^ that is expected.  
However, if I click the button to update the facts in the gui, I am NOT getting the same error message.  Instead I get "[Errno 111] Connection refused".  See attached screenshot.  I would expect to see the same message that I get in the CLI.


Problem 2:
The error dialog that you see in the attached screenshot is not modal to the facts dialog (instead it is modal to the main subscription manager window) which means that you can click on the facts dialog thereby raising it above the error dialog thereby hiding the error dialog which has a grab on the input leaving you unable to click the Close button in the facts dialog.  The error dialog should really be modal to the main subscription manager window OR the top most child window currently being displayed.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.96.5-1.git.16.531d88e.el6.x86_64
subscription-manager-0.96.5-1.git.16.531d88e.el6.x86_64
subscription-manager-gnome-0.96.5-1.git.16.531d88e.el6.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Question... the Network Error message appears to have recently changed.  A new-line character appears to have been placed between the sentences.

Network error, unable to connect to server.
 Please see /var/log/rhsm/rhsm.log for more information.

^ THIS NEW LINE CHARACTER WAS RECENTLY ADDED.  WAS THIS DONE DELIBERATELY?  MY AUTOMATED TESTS TRIPPED UP ON THIS TODAY.
Comment 2 John Sefler 2011-08-10 15:59:31 EDT
[root@jsefler-onprem-62server ~]# tail -f /var/log/rhsm/rhsm.log

2011-08-10 15:57:40,966 [INFO]  @facts.py:170 - Updating facts.
2011-08-10 15:57:40,968 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-10 15:57:40,969 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-10 15:57:40,970 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-10 15:57:40,971 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-10 15:57:40,974 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-10 15:57:40,981 [DEBUG]  @connection.py:181 - Using proxy: auto-services.usersys.redhat.com:31280
2011-08-10 15:57:40,983 [DEBUG]  @connection.py:196 - Making request: PUT https://jsefler-onprem-62candlepin.usersys.redhat.com:8443/candlepin/consumers/c6843da2-cb00-469d-882b-dedc76df2832
2011-08-10 15:57:40,989 [ERROR]  @factsgui.py:120 - Could not update system facts 
Error: [Errno 111] Connection refused
2011-08-10 15:57:41,172 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-10 15:57:41,173 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-10 15:57:41,173 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-10 15:57:41,174 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-10 15:57:41,177 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-10 15:57:41,179 [DEBUG]  @connection.py:181 - Using proxy: auto-services.usersys.redhat.com:31280
2011-08-10 15:57:41,180 [DEBUG]  @connection.py:196 - Making request: GET https://jsefler-onprem-62candlepin.usersys.redhat.com:8443/candlepin/consumers/c6843da2-cb00-469d-882b-dedc76df2832/owner
2011-08-10 15:57:41,185 [ERROR]  @factsgui.py:110 - Could not get owner name 
Error: [Errno 111] Connection refused
Comment 3 Chris Duryee 2011-09-09 11:26:26 EDT
ac50478b99263d77892b3920e4364490cf95f44c master 0.96.9+

(I fixed this on 8/15 and forgot to update the bz until now, oops)
Comment 4 John Sefler 2011-09-12 17:46:01 EDT
Created attachment 522806 [details]
"Error updating system data" is properly displayed in gui when proxy is bad.

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.96.9-1.git.10.adab5e3.el6.x86_64
subscription-manager-0.96.9-1.git.10.adab5e3.el6.x86_64
subscription-manager-firstboot-0.96.9-1.git.10.adab5e3.el6.x86_64


With the same bad proxy settings as listed above...

[root@jsefler-onprem-62server ~]# subscription-manager facts --update
Error updating system data, see /var/log/rhsm/rhsm.log for more details.

and when I start the gui and click "update Facts" I now get the same error message.   See the screenshot.


Problem 1 is VERIFIED


Additional info:
Following is a tail of the /var/log/rhsm/rhsm.log 

2011-09-12 17:35:55,014 [INFO]  @cache.py:154 - Checking current system info against cache: /var/lib/rhsm/facts/facts.json
2011-09-12 17:35:55,033 [INFO]  @cache.py:156 - System data has changed, updating server.
2011-09-12 17:35:55,034 [DEBUG]  @connection.py:188 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-09-12 17:35:55,035 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/jsefler-f14-5beakerpin.pem'
2011-09-12 17:35:55,035 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-09-12 17:35:55,036 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-09-12 17:35:55,036 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/jsefler-f14-6beakerpin.pem'
2011-09-12 17:35:55,037 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-09-12 17:35:55,038 [DEBUG]  @connection.py:194 - Using proxy: auto-services.usersys.redhat.com:31280
2011-09-12 17:35:55,038 [DEBUG]  @connection.py:209 - Making request: PUT https://jsefler-onprem-62candlepin.usersys.redhat.com:8443/candlepin/consumers/59f3a765-8ef8-4e5f-b2c3-b481b15762ee
2011-09-12 17:35:55,100 [ERROR]  @cache.py:164 - Error updating system data
2011-09-12 17:35:55,101 [ERROR]  @cache.py:165 - [Errno 111] Connection refused
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/cache.py", line 158, in update_check
    self._update_server(uep, consumer_uuid)
  File "/usr/share/rhsm/subscription_manager/facts.py", line 135, in _update_server
    uep.updateConsumer(consumer_uuid, facts=self.get_facts())
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 448, in updateConsumer
    ret = self.conn.request_put(method, params)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 261, in request_put
    return self._request("PUT", method, params)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 212, in _request
    conn.request(request_type, handler, body=body, headers=headers)
  File "/usr/lib64/python2.6/httplib.py", line 914, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 951, in _send_request
    self.endheaders()
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 105, in endheaders
    httpslib.HTTPSConnection.endheaders(self)
  File "/usr/lib64/python2.6/httplib.py", line 908, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 780, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 739, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 169, in connect
    HTTPConnection.connect(self)
  File "/usr/lib64/python2.6/httplib.py", line 720, in connect
    self.timeout)
  File "/usr/lib64/python2.6/socket.py", line 567, in create_connection
    raise error, msg
error: [Errno 111] Connection refused
2011-09-12 17:35:55,104 [ERROR]  @factsgui.py:121 - Could not update system facts 
Error: Error updating system data, see /var/log/rhsm/rhsm.log for more details.
2011-09-12 17:35:55,105 [ERROR]  @utils.py:53 - Error updating system data, see /var/log/rhsm/rhsm.log for more details.
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/factsgui.py", line 119, in update_facts
    self.facts.update_check(self.backend.uep, consumer_uuid, force=True)
  File "/usr/share/rhsm/subscription_manager/cache.py", line 166, in update_check
    raise Exception(_("Error updating system data, see /var/log/rhsm/rhsm.log "
Exception: Error updating system data, see /var/log/rhsm/rhsm.log for more details.
2011-09-12 17:35:55,174 [DEBUG]  @connection.py:188 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-09-12 17:35:55,174 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/jsefler-f14-5beakerpin.pem'
2011-09-12 17:35:55,175 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-09-12 17:35:55,175 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-09-12 17:35:55,176 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/jsefler-f14-6beakerpin.pem'
2011-09-12 17:35:55,176 [DEBUG]  @connection.py:171 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-09-12 17:35:55,177 [DEBUG]  @connection.py:194 - Using proxy: auto-services.usersys.redhat.com:31280
2011-09-12 17:35:55,177 [DEBUG]  @connection.py:209 - Making request: GET https://jsefler-onprem-62candlepin.usersys.redhat.com:8443/candlepin/consumers/59f3a765-8ef8-4e5f-b2c3-b481b15762ee/owner
2011-09-12 17:35:55,181 [ERROR]  @factsgui.py:111 - Could not get owner name 
Error: [Errno 111] Connection refused
Comment 5 John Sefler 2011-09-12 18:02:50 EDT
Chris,
Although Problem 1 is VERIFIED, Problem 2 in comment 0 is still present.

Moving this bug to VERIFIED and opened separate bug 737696
Comment 6 errata-xmlrpc 2011-12-06 12:23:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.