Bug 737696 - error dialog can get trapped/hidden behind Subscription Manager - Facts dialog
Summary: error dialog can get trapped/hidden behind Subscription Manager - Facts dialog
Keywords:
Status: CLOSED DUPLICATE of bug 705883
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: beta
: 5.8
Assignee: Devan Goodwin
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 715031
TreeView+ depends on / blocked
 
Reported: 2011-09-12 22:01 UTC by John Sefler
Modified: 2011-11-23 17:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-23 17:06:01 UTC


Attachments (Terms of Use)
error dialog that can get trapped/hidden behind facts dialog (249.73 KB, image/png)
2011-09-12 22:01 UTC, John Sefler
no flags Details

Description John Sefler 2011-09-12 22:01:53 UTC
Created attachment 522809 [details]
error dialog that can get trapped/hidden behind facts dialog

Description of problem:
Originally reported as part of bug 729688...

The error dialog that you see in the attached screenshot is not modal to the
facts dialog (instead it is modal to the main subscription manager window)
which means that you can click on the facts dialog thereby raising it above the
error dialog thereby hiding the error dialog which has a grab on the input
leaving you unable to click the Close button in the facts dialog.  The error
dialog should really be modal to the main subscription manager window OR the
top most child window currently being displayed.

To cause the error condition...
1.Use the cli to register
2.change the proxy settings in rhsm.conf to something bad
3.start the gui
4.click View System Facts / Update Facts

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.96.9-1.git.10.adab5e3.el6.x86_64
subscription-manager-0.96.9-1.git.10.adab5e3.el6.x86_64
subscription-manager-firstboot-0.96.9-1.git.10.adab5e3.el6.x86_64

Comment 3 Devan Goodwin 2011-11-23 17:06:01 UTC
Confirmed duplicate.

*** This bug has been marked as a duplicate of bug 705883 ***


Note You need to log in before you can comment on or make changes to this bug.