Bug 729950 - Tracing Framework does not work
Summary: Tracing Framework does not work
Keywords:
Status: CLOSED DUPLICATE of bug 720979
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jes Sorensen
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 11:13 UTC by Mike Cao
Modified: 2013-01-10 00:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-12 07:05:47 UTC


Attachments (Terms of Use)

Description Mike Cao 2011-08-11 11:13:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.169.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.install system ,kernel-devel.kernel-debug
2.# cat /home/balloon.stp 
probe qemu.kvm.balloon_event
{  printf("opaque = %p,  addr =%u ",opaque,addr);

}

3.stap balloon.stp
  
Actual results:
# stap /home/balloon.stp 
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:260:8
     source:   next = $arg3;
                    ^
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:289:8
     source:   next = $arg3;
                    ^
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:315:8
     source:   next = $arg2;
                    ^
3 parse errors.
WARNING: tapset '/usr/share/systemtap/tapset/qemu-kvm.stp' has errors, and will be skipped.
semantic error: probe point mismatch at position 0  (alternatives: __nfs __scheduler __signal __tcpmib __vm _linuxmib _signal _sunrpc _syscall _vfs begin begin(number) end end(number) error error(number) generic ioblock ioblock_trace ioscheduler ioscheduler_trace ipmib irq_handler kernel kprobe kprocess linuxmib module(string) nd_syscall netdev never nfs nfsd perf process process(number) process(string) procfs procfs(string) python scheduler scsi signal socket softirq stap staprun sunrpc syscall tcp tcpmib timer tty udp vfs vm workqueue): identifier 'qemu' at /home/balloon.stp:1:7 while resolving probe point qemu.kvm.balloon_event
        source: probe qemu.kvm.balloon_event
                      ^
Pass 2: analysis failed.  Try again with another '--vp 01' option.

Expected results:
the script should work

Additional info:
1.The issue does not on qemu-kvm-0.12.1.2-2.159.el6.x86_64.rpm
2.I think the issue regressioned from the usb series patch.

Comment 3 Jes Sorensen 2011-08-12 06:35:56 UTC
I am not an expert on systemtap, but it looks like the error is due to the
'=' signs in your script. Try removing them and see if it makes the problem
go away, like this:

{  printf("opaque: %p,  addr: %u ",opaque,addr);

}

Also do you not have to reference the variables as $opaque, $addr?

Cheers,
Jes

Comment 4 Amit Shah 2011-08-12 07:05:47 UTC

*** This bug has been marked as a duplicate of bug 720979 ***

Comment 5 Mike Cao 2011-08-12 07:08:30 UTC
(In reply to comment #3)
> I am not an expert on systemtap, but it looks like the error is due to the
> '=' signs in your script. Try removing them and see if it makes the problem
> go away, like this:
> 
> {  printf("opaque: %p,  addr: %u ",opaque,addr);
> 
> }
> 
> Also do you not have to reference the variables as $opaque, $addr?
> 
> Cheers,
> Jes

it does not work.


Note You need to log in before you can comment on or make changes to this bug.