Bug 73002 - Unexpected behavior suspending man
Summary: Unexpected behavior suspending man
Status: CLOSED DUPLICATE of bug 82261
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-08-29 21:00 UTC by Peter Jones
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Jones 2002-08-29 21:00:09 UTC
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. man ls
2. ^Z
3. up arrow

Actual Results:
Control characters on the command line.

Expected Results:
Command history.


Additional Information:
Happens in gnome-terminal and rxvt, but not on the console.  Also, I think this
is groff (as opposed to man, less, bash, or the terminal) because the problem
doesn't occur if you scroll to the end of the man page before suspending.  At
this point groff has finished rendering the page and terminated.

Comment 1 Florian La Roche 2003-01-18 08:53:08 UTC
This is due to how man handels signals and ttys.

greetings,

Florian La Roche


Comment 2 Eido Inoue 2003-08-07 21:48:42 UTC

*** This bug has been marked as a duplicate of 82261 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:49:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.