Bug 730057 - quota_nld: Failed to find tty of user 0 to report warning to.
Summary: quota_nld: Failed to find tty of user 0 to report warning to.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: quota
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Branislav Blaškovič
URL: https://sourceforge.net/tracker/?func...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 16:20 UTC by seth vidal
Modified: 2013-07-29 01:59 UTC (History)
4 users (show)

Fixed In Version: quota-3.17-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: Excessing disk quota limit for user without interactive session while running quota_nld service. Consequence: quota_nld service complains into system log `Failed to find tty of user 0 to report warning to'. Fix: The warning emission has been constrained to non-daemon debugging mode of quota_nld only. Result: quota_nld service does not report this failure into system log anymore.
Clone Of:
: 731622 (view as bug list)
Environment:
Last Closed: 2012-11-19 13:32:03 UTC


Attachments (Terms of Use)
Proposed fix (1.13 KB, patch)
2011-08-17 15:15 UTC, Petr Pisar
no flags Details | Diff
Fix (1.21 KB, patch)
2011-08-18 06:04 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1472 normal SHIPPED_LIVE quota bug fix update 2012-11-19 18:31:11 UTC

Description seth vidal 2011-08-11 16:20:57 UTC
Description of problem:
We are getting this log warning:
quota_nld: Failed to find tty of user 0 to report warning to. 

over and over again in our logs on rhel 6.1 + updates


Version-Release number of selected component (if applicable):
quota-3.17-16.el6.fi.1.x86_64

this has a small fix provided by you for our use of nss_db

How reproducible:
We don't know how to reproduce it, we'd like it to stop or at least be explained.

Comment 2 RHEL Product and Program Management 2011-08-11 16:48:01 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Petr Pisar 2011-08-17 11:46:43 UTC
If your build applies patch from bug #704216 (the one-liner), then the patch  could not have impact on quota_nld executable as it modifies edquota.c only that is not linked to quota_nld. Can you reproduce this bug with vanilla RHEL-6.1 quota package?

I'm not able to reproduce this bug in RHEL-6.2. I will check RHEL-6.1. Note both distributions contain the same quota version.

Do you have some file system where quota limits are exceeded for root user? quota_nld daemon prints warning at time of excessing limit to terminal the user in question is logged on.

The daemon obviously cannot find terminal root is logged in (utmp database is searched for this purpose). You can stop the daemon (service quota_nld stop), if do not need quota excess warnings at all. Or if you want to get warnings through D-bus yet, you can disable the warnings to console by editing /etc/sysconf/quota_nld.

Comment 4 Petr Pisar 2011-08-17 13:47:56 UTC
I achieve to reproduce it. It's not caused by the patch.

This happens if limits exceeds for user having no interactive session. More precisely if utmp database is missing records for given user.

Reproducer:

1. Enable quotas on a file system and set limit for a user.
2. Start quota_nld service.
3. Log in as the user and start a screen session (make sure no other sessions
   for that user exist).
4. Run a delayed command that exceeds the limit. E.g:
   # sleep 3; dd if=/dev/zero of=file bs=1k count=200
5. Detach from session and log out before the command takes effect (3 seconds
   in this example).

You will get the error message in system log because quota_nld daemon could not find a record for the user in /var/log/wtmp.

Comment 5 Petr Pisar 2011-08-17 15:15:29 UTC
Created attachment 518705 [details]
Proposed fix

This patch suppress writing this one error message into syslog.

Comment 6 Petr Pisar 2011-08-17 15:29:57 UTC
Patch submitted to upstream for review (https://sourceforge.net/tracker/?func=detail&aid=3393151&group_id=18136&atid=318136).

Comment 7 Petr Pisar 2011-08-18 06:04:05 UTC
Created attachment 518805 [details]
Fix

The patch has been accepted by upstream in slightly more commented form.

Comment 9 Suzanne Yeghiayan 2012-02-14 23:13:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 18 errata-xmlrpc 2012-11-19 13:32:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1472.html


Note You need to log in before you can comment on or make changes to this bug.