Bug 731622 - quota_nld: Failed to find tty of user 0 to report warning to.
Summary: quota_nld: Failed to find tty of user 0 to report warning to.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: quota
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/tracker/?func...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 06:10 UTC by Petr Pisar
Modified: 2014-01-21 06:24 UTC (History)
3 users (show)

Fixed In Version: quota-4.00-0.14.pre1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of: 730057
Environment:
Last Closed: 2011-08-28 05:35:30 UTC


Attachments (Terms of Use)

Description Petr Pisar 2011-08-18 06:10:03 UTC
+++ This bug was initially created as a clone of Bug #730057 +++

Description of problem:
We are getting this log warning:
quota_nld: Failed to find tty of user 0 to report warning to. 

over and over again in our logs on rhel 6.1 + updates


Version-Release number of selected component (if applicable):
quota-3.17-16.el6.fi.1.x86_64

this has a small fix provided by you for our use of nss_db

How reproducible:
We don't know how to reproduce it, we'd like it to stop or at least be explained.

[...]

--- Additional comment from ppisar@redhat.com on 2011-08-17 13:47:56 GMT ---

I achieve to reproduce it. It's not caused by the patch.

This happens if limits exceeds for user having no interactive session. More precisely if utmp database is missing records for given user.

Reproducer:

1. Enable quotas on a file system and set limit for a user.
2. Start quota_nld service.
3. Log in as the user and start a screen session (make sure no other sessions
   for that user exist).
4. Run a delayed command that exceeds the limit. E.g:
   # sleep 3; dd if=/dev/zero of=file bs=1k count=200
5. Detach from session and log out before the command takes effect (3 seconds
   in this example).

You will get the error message in system log because quota_nld daemon could not find a record for the user in /var/log/wtmp.

[...]

--- Additional comment from ppisar@redhat.com on 2011-08-17 15:29:57 GMT ---

Patch submitted to upstream for review (https://sourceforge.net/tracker/?func=detail&aid=3393151&group_id=18136&atid=318136).

--- Additional comment from ppisar@redhat.com on 2011-08-18 06:04:05 GMT ---

Created attachment 518805 [details]
Fix

The patch has been accepted by upstream in slightly more commented form.
-----

All Fedoras affected.

Comment 1 Fedora Update System 2011-08-18 07:25:12 UTC
quota-4.00-0.17.pre1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/quota-4.00-0.17.pre1.fc16

Comment 2 Fedora Update System 2011-08-18 07:25:44 UTC
quota-4.00-0.14.pre1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/quota-4.00-0.14.pre1.fc15

Comment 3 Fedora Update System 2011-08-18 07:26:25 UTC
quota-3.17-18.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/quota-3.17-18.fc14

Comment 4 Fedora Update System 2011-08-18 22:03:35 UTC
Package quota-4.00-0.17.pre1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quota-4.00-0.17.pre1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/quota-4.00-0.17.pre1.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-08-28 05:35:24 UTC
quota-4.00-0.17.pre1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-08-31 01:37:13 UTC
quota-3.17-18.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-08-31 01:41:44 UTC
quota-4.00-0.14.pre1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.