Bug 730124 - F16: grub hangs at boot with black screen and cursor (EFI, 2011 mac mini)
F16: grub hangs at boot with black screen and cursor (EFI, 2011 mac mini)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
16
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-11 16:10 EDT by Jurgen Kramer
Modified: 2011-11-25 10:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-07 14:03:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2011-08-11 16:10:11 EDT
Description of problem:
when booting with F16rc3 on my 2011 mac mini grub hangs with a black screen and non-blinking cursor.

Version-Release number of selected component (if applicable):
grub2-1.99-0.2.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install F16 x86_64 rc3 from DVD
2. Reboot after installation is finished (EFI install)
3.
  
Actual results:
grub hangs with a black screen and non-blinking cursor.

Expected results:
grub shows boot menu

Additional info:
As anaconda sets the efi boot order so grub is the default it makes the system complete useless with grub hanging. When the system is booted with the ALT key held down I can select to start Refit and the boot order is reset.
When starting grub from refit I get the same black screen with cursor (_)
Comment 1 Jurgen Kramer 2011-08-12 03:12:07 EDT
modified component from grub2 to grub as grub is being used instead of grub2
Comment 2 Jurgen Kramer 2011-08-12 06:05:45 EDT
When I move grub.conf out of the way I get the grub prompt. Issuing manual commands to load the kernel and ramdisk work fine. When I give the boot command the system hangs.

Output of my commands (copied from the screen by hand):

grub> root (hd0,03)
 Filesystem type is ext2fs, partition type 0x83

grub> kernel /vmlinuz-3.0.0-1.fc16.x86_64
Trying to allocate 1031 pages for VMLINUZ
Got pages at 0x77117000
[Linux-EFI, setup=0x101d, size=0x406ad0]

grub> initrd /initramfs-3.0.0-1.fc16.x86_64.img
   [Initrd, addr=0x7622a000, size=0xeex125]

grub> boot
_
<hangs>

Any magic commands, grub or kernel, to try to get it booting?
Comment 3 Jurgen Kramer 2011-08-16 13:13:21 EDT
With F16 Alpha RC4 the problem is still there. grub hangs with black screen.
Comment 4 Jurgen Kramer 2011-08-17 03:20:18 EDT
Sigh, still the same problem with F16 Alpha RC5.
Comment 5 Jurgen Kramer 2011-08-17 04:37:08 EDT
I managed to install grub2 onto my boot partition and manually boot the system by issuing the needed commands on the grub2 prompt. I can now debug further from there.

Conclusion: the 2011 mac mini needs grub2 to boot F16.
Comment 6 Lars Seipel 2011-08-29 10:45:12 EDT
You have to specify a root filesystem on the kernel commandline. Then it'll work I guess.

Does your grub.conf contain an initrd entry for the default kernel? There seems to be a problem where it gets omitted on kernel update. I got hit by this and filed #733851. Probably it's the same issue.
Comment 7 Jurgen Kramer 2011-08-29 11:33:37 EDT
My system boots fine with grub2 and grub2-efi. With legacy grub the hangs hangs after issuing the boot command (comment #2) so it does not even come to the point where it needs a root filesystem. The grub.conf file from grub legacy was correct.
Comment 8 Lars Seipel 2011-08-29 12:15:34 EDT
In comment #2 you specify the kernel to be booted before issuing the boot command on the grub commandline. You have to provide a root filesystem to the kernel in the form of root=device.

Example:
grub> kernel /vmlinuz-3.0.0-1.fc16.x86_64 root=/dev/sdxy

Better use UUIDs though.
Comment 9 solanum 2011-09-11 01:04:40 EDT
This is close to 733186 although different as hardware is acting slightly different.
Comment 10 Jurgen Kramer 2011-09-22 14:16:12 EDT
I suggest to close this bug. I've already opened BZ #738969 which supersedes this (for me at least).
Comment 11 Jurgen Kramer 2011-10-07 14:03:34 EDT
Further tracking of grub issues EFI boot on macmini5,1 in BZ #743330

Note You need to log in before you can comment on or make changes to this bug.