Bug 73017 - wrong kernel arch selected on Athlon system
wrong kernel arch selected on Athlon system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 73257 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 19:01 EDT by tom georgoulias
Modified: 2015-01-07 19:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 13:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tom georgoulias 2002-08-29 19:01:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
up2date downloaded the header file for i586, even though I'm running an athlon
kernel on an Athlon CPU.

Version-Release number of selected component (if applicable):
up2date-2.9.46-1

How reproducible:
Every time.

Steps to Reproduce:
1. up2date -l as root.


Actual Results:  kernel-2.4.18-12.5.i586.hdr was downloaded.

Expected Results:  kernel-2.4.18-12.5.athlon.hdr should've been selected &
downloaded.

Additional info:

[tomg@gemini rpm]$ rpm -q --queryformat '%{arch}\n' kernel
i686
athlon
[tomg@gemini rpm]$ ls -ld
/var/spool/up2date/kernel-2.4.18-12.5.i586.hdr-rw-r--r--    1 root     root    
  167909 Aug 29 17:53 /var/spool/up2date/kernel-2.4.18-12.5.i586.hdr
[tomg@gemini rpm]$ uname -a
Linux gemini 2.4.18-12.2 #1 Mon Aug 19 11:01:05 EDT 2002 i686 unknown unknown
GNU/Linux
[tomg@gemini rpm]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) processor
stepping        : 2
cpu MHz         : 1336.465
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips        : 2652.30
Comment 1 Alexandre Oliva 2002-08-29 21:13:32 EDT
ditto for glibc: it downloaded and installed the .i386 variant instead of the
.i686 one on my athlon box.
Comment 2 Michael Young 2002-08-30 07:52:48 EDT
It is not restricted to athlons either. up2date gave me an i386 glibc and
offered me a i586 kernel, for an i686 machine.
Comment 3 Adrian Likins 2002-08-30 19:30:00 EDT
hmm, grumble. I dont recall touching that code in a
long time. Not sure what the heck is going on here....

investigating...
Comment 4 Adrian Likins 2002-08-30 19:53:53 EDT
aieee, I found it. 

I'm a moron. I broke this real good. Should be fixed in 2.9.62 or
higher.
Comment 5 Adrian Likins 2002-09-01 20:40:47 EDT
*** Bug 73257 has been marked as a duplicate of this bug. ***
Comment 6 Matt Jamison 2003-09-11 13:35:43 EDT
yep, is fixed.

resolving

Note You need to log in before you can comment on or make changes to this bug.