Bug 730300 - internal compiler error: in new_elt_loc_list, at cselib.c:238
Summary: internal compiler error: in new_elt_loc_list, at cselib.c:238
Keywords:
Status: CLOSED DUPLICATE of bug 715336
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 12:05 UTC by Oliver Henshaw
Modified: 2011-08-12 13:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 715336
Environment:
Last Closed: 2011-08-12 13:27:02 UTC


Attachments (Terms of Use)
Preprocessed source (717.32 KB, text/plain)
2011-08-12 12:09 UTC, Oliver Henshaw
no flags Details

Description Oliver Henshaw 2011-08-12 12:05:47 UTC
I see this in f15, while trying to rebuild ImageMagick locally in mock.

$ rpm -qa gcc\*
gcc-4.6.0-10.fc15.x86_64
gcc-debuginfo-4.6.0-10.fc15.x86_64
gcc-base-debuginfo-4.6.0-10.fc15.x86_64
gcc-c++-4.6.0-10.fc15.x86_64


+++ This bug was initially created as a clone of Bug #715336 +++

Description of problem:
Rest of ImageMagick compilation on rawhide (also http://koji.fedoraproject.org/koji/getfile?taskID=3152856&name=build.log):

/bin/sh ./libtool --silent --tag=CC   --mode=compile gcc -std=gnu99 -std=gnu99 -DHAVE_CONFIG_H -I. -I./config  -I./ltdl -I./ltdl  -I/usr/include/freetype2 -I/usr/include/libxml2  -fopenmp -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -pthread -c -o magick/magick_libMagickCore_la-xwindow.lo `test -f 'magick/xwindow.c' || echo './'`magick/xwindow.c
magick/xwindow.c: In function 'XMakeMagnifyImage':
magick/xwindow.c:7505:1: internal compiler error: in new_elt_loc_list, at cselib.c:238
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccl08Cy0.out file, please attach this to your bugreport.
make[1]: *** [magick/magick_libMagickCore_la-xwindow.lo] Error 1
make[1]: Leaving directory `/home/fedora/hubbitus/rpmbuild/BUILD/ImageMagick-6.7.0-8'
make: *** [all] Error 2

It is not reproduced on Fedora 14.

Mentioned file attached.

Version-Release number of selected component (if applicable):
$ rpm -qa gcc\*
gcc-c++-4.6.0-10.fc16.x86_64
gcc-gfortran-4.6.0-10.fc16.x86_64
gcc-4.6.0-10.fc16.x86_64
gcc-objc-4.6.0-10.fc16.x86_64
gcc-gnat-4.6.0-10.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
Build new ImageMagick (can src.rpm, it is not in git yet)

Comment 1 Oliver Henshaw 2011-08-12 12:09:24 UTC
Created attachment 518018 [details]
Preprocessed source

Comment 2 Pavel Alexeev 2011-08-12 13:27:02 UTC

*** This bug has been marked as a duplicate of bug 715336 ***


Note You need to log in before you can comment on or make changes to this bug.