Bug 715336 - internal compiler error: in new_elt_loc_list, at cselib.c:238
internal compiler error: in new_elt_loc_list, at cselib.c:238
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 730300 740412 (view as bug list)
Depends On:
Blocks: 715834
  Show dependency treegraph
 
Reported: 2011-06-22 10:55 EDT by Pavel Alexeev
Modified: 2011-09-22 13:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 730300 (view as bug list)
Environment:
Last Closed: 2011-07-04 10:09:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mentioned preprocessed source (720.37 KB, application/octet-stream)
2011-06-22 10:56 EDT, Pavel Alexeev
no flags Details

  None (edit)
Description Pavel Alexeev 2011-06-22 10:55:19 EDT
Description of problem:
Rest of ImageMagick compilation on rawhide (also http://koji.fedoraproject.org/koji/getfile?taskID=3152856&name=build.log):

/bin/sh ./libtool --silent --tag=CC   --mode=compile gcc -std=gnu99 -std=gnu99 -DHAVE_CONFIG_H -I. -I./config  -I./ltdl -I./ltdl  -I/usr/include/freetype2 -I/usr/include/libxml2  -fopenmp -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -pthread -c -o magick/magick_libMagickCore_la-xwindow.lo `test -f 'magick/xwindow.c' || echo './'`magick/xwindow.c
magick/xwindow.c: In function 'XMakeMagnifyImage':
magick/xwindow.c:7505:1: internal compiler error: in new_elt_loc_list, at cselib.c:238
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccl08Cy0.out file, please attach this to your bugreport.
make[1]: *** [magick/magick_libMagickCore_la-xwindow.lo] Error 1
make[1]: Leaving directory `/home/fedora/hubbitus/rpmbuild/BUILD/ImageMagick-6.7.0-8'
make: *** [all] Error 2

It is not reproduced on Fedora 14.

Mentioned file attached.

Version-Release number of selected component (if applicable):
$ rpm -qa gcc\*
gcc-c++-4.6.0-10.fc16.x86_64
gcc-gfortran-4.6.0-10.fc16.x86_64
gcc-4.6.0-10.fc16.x86_64
gcc-objc-4.6.0-10.fc16.x86_64
gcc-gnat-4.6.0-10.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
Build new ImageMagick (can src.rpm, it is not in git yet)
Comment 1 Pavel Alexeev 2011-06-22 10:56:51 EDT
Created attachment 506028 [details]
Mentioned preprocessed source
Comment 2 Jakub Jelinek 2011-07-04 08:15:11 EDT
Please retry with gcc-4.6.1-1.fc16.
Comment 3 Pavel Alexeev 2011-07-04 10:09:36 EDT
Thanks, now it built http://koji.fedoraproject.org/koji/taskinfo?taskID=3178795
Comment 4 Pavel Alexeev 2011-08-12 09:27:03 EDT
*** Bug 730300 has been marked as a duplicate of this bug. ***
Comment 5 Oliver Henshaw 2011-08-12 09:45:49 EDT
(In reply to comment #4)
> *** Bug 730300 has been marked as a duplicate of this bug. ***

Please re-open this bug and change version to F15.
Comment 6 Pavel Alexeev 2011-08-12 12:50:56 EDT
For what? Problem gone, fix already in rawhide.
Comment 7 Oliver Henshaw 2011-08-12 13:40:47 EDT
Because the problem exists in Fedora 15 too, and is preventing me from rebuilding ImageMagick locally.

(I'm trying to test a fix for a bug I encountered, see http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=19215&sid=92d2d107379cfc06193f308603a89948&p=75054#p75066 )
Comment 8 Pavel Alexeev 2011-08-14 14:03:38 EDT
Rebuild new, actual version, at least what in rawhide.

This is development issue, and none updates in stable version will be done for it.
Comment 9 Oliver Henshaw 2011-08-20 09:14:23 EDT
I'm not sure whether you're talking about gcc or ImageMagick here. Nevertheless, I have filed bug #732187 for the ImageMagick regression and note that this gcc bug prevents me backporting the fix to my F15 system (and would also prevent a security update from building) and that the fixed version of ImageMagick isn't yet available in rawhide.
Comment 10 Pavel Alexeev 2011-08-22 03:07:05 EDT
Thanks, for that report, it fixed. But I think it is not so important bug (obviousely it is not security related or system wide) to initiate mass rebuild of dependencies.
Comment 11 Oliver Henshaw 2011-08-22 10:43:35 EDT
Oh, OK. Is it possible to backport the fix without requiring dependencies to be rebuilt?
Comment 12 Pavel Alexeev 2011-08-23 06:07:51 EDT
No. Even if there wasn't soname bump hapepend at least some dependencies like ruby-rmagick uses full versioned dependencies.

And for what? Just install rawhide version to test it fixed. It works like a sharm.
Comment 13 Jakub Jelinek 2011-09-22 13:58:50 EDT
*** Bug 740412 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.