Bug 73041 - Documentation category not showing up automatically
Documentation category not showing up automatically
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-29 23:00 EDT by Tammy Fox
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 10:57:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2002-08-29 23:00:24 EDT
If I install one of the rhl-*-en package from docs, I have
to do a killall gnome-panel for it to show up with gnome-panel version 2.0.6-8.
Comment 1 Jonathan Blandford 2003-01-31 19:26:07 EST
As much as I hate to say it, you're the menu master now, Havoc.  Is this fixed
in the next release?
Comment 2 Havoc Pennington 2003-01-31 19:35:40 EST
at the moment we're using the same menu code as in 8.0, without changes.
Comment 3 Leonard den Ottolander 2004-02-26 07:19:31 EST
Where should/do the docs show up? In the menu? I want to know so I can
see if this is still an issue with FC 1. Is it an issue with RHEL 3?
If not, probably no problem with FC 1 either, in which case this one
could be closed NEXTRELEASE.
Comment 4 Mark McLoughlin 2004-02-27 10:10:05 EST
Yeah, I don't get this either.

Tammy: I know this is going back a long way, but where was it not
"showing up"?

Comment 5 Tammy Fox 2004-02-27 10:55:12 EST
In the main menu. When you install a docs package from RH, it adds a
desktop file in /usr/share/applications/ with
Cateogories=Documentation;X-Red-Hat-Base; so that it should appear
under the Documentation category off the main menu (the red fedora on
the panel).

When I filed this bug, Havoc said that the Documentation category
should only appear if there are items in it, which totally makes
sense. The problem was that it was not refreshing after installing an
RPM that added a desktop file for this category. I had to kill the
panel to force it to re-read to the desktop file with the otherwise
hidden category.

On an FC1 system, I installed rhel-sag-en-3-2.noarch.rpm from RHEL 3,
and it seems fixed now. After installing the RPM, I looked in the menu
and it had the Documentation category added with the menu item.

You might want to test it again on a different system just to be sure.
Comment 6 Mark McLoughlin 2004-02-27 10:57:44 EST
Ah, okay, I see now. Yes, this should work fine these days.

Thanks Tammy.

Note You need to log in before you can comment on or make changes to this bug.