Bug 730499 - AVC against exim with unconfined off.
Summary: AVC against exim with unconfined off.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 732225 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-13 19:26 UTC by Robin Powell
Modified: 2011-10-06 00:02 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.9.16-39.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-06 00:02:35 UTC


Attachments (Terms of Use)

Description Robin Powell 2011-08-13 19:26:34 UTC
Note that I've seen no actual *problem* here, but with exim running I'm getting:

type=AVC msg=audit(1313231101.900:312918): avc:  denied  { write } for  pid=4641 comm="exim_tidydb" name="wait-remote_smtp.lockfile" dev=vda2 ino=6313 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:exim_spool_t:s0 tclass=file

Which appears to be caused by /etc/cron.daily/exim-tidydb

audit2allow says:

allow system_cronjob_t exim_spool_t:file write;

I imagine there's something in the cron or exim interfaces that would be better, but I also imagine y'all can find it faster than I can.  :)

-Robin

Comment 1 Daniel Walsh 2011-08-15 10:47:07 UTC
If you chcon -t exim_exec_t exim_tidydb

Does it solve the problem?

Comment 2 Robin Powell 2011-08-21 02:54:39 UTC
I'll see for sure tonight, but my manual test run indicates that it does fix it, yes.

-Robin

Comment 3 Miroslav Grepl 2011-08-22 12:16:22 UTC
*** Bug 732225 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-09-08 08:12:08 UTC
selinux-policy-3.9.16-39.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-39.fc15

Comment 5 Fedora Update System 2011-09-09 05:28:17 UTC
Package selinux-policy-3.9.16-39.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-39.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-39.fc15
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-10-06 00:02:35 UTC
selinux-policy-3.9.16-39.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.