Bug 732225 - exim cron.daily/exim_tidydb AVCs with unconfined disabled.
Summary: exim cron.daily/exim_tidydb AVCs with unconfined disabled.
Keywords:
Status: CLOSED DUPLICATE of bug 730499
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 01:16 UTC by Robin Powell
Modified: 2011-08-22 12:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 12:16:22 UTC


Attachments (Terms of Use)

Description Robin Powell 2011-08-21 01:16:04 UTC
I ran this with setenforce 0, it matches what the nightly run produced:

sudo runcon system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 /etc/cron.daily/exim-tidydb

Result:

type=AVC msg=audit(1313877332.182:692936): avc:  denied  { write } for  pid=13815 comm="exim_tidydb" name="retry.lockfile" dev=vda2 ino=6311 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:exim_spool_t:s0 tclass=file

-Robin

Comment 1 Robin Powell 2011-08-21 02:53:27 UTC
Crap, this is a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=730499 ; the chcon that dwalsh suggested fixed this problem.

Sorry about that.

-Robin

Comment 2 Miroslav Grepl 2011-08-22 12:16:22 UTC

*** This bug has been marked as a duplicate of bug 730499 ***


Note You need to log in before you can comment on or make changes to this bug.