Bug 730578 - Non-fatal POSTIN scriptlet failure in rpm package glibc-2.14-5.x86_64
Summary: Non-fatal POSTIN scriptlet failure in rpm package glibc-2.14-5.x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 698198
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-14 15:53 UTC by Jonathan Wakely
Modified: 2016-11-24 16:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-15 07:28:55 UTC


Attachments (Terms of Use)

Description Jonathan Wakely 2011-08-14 15:53:18 UTC
Description of problem:

error during yum update of glibc

Version-Release number of selected component (if applicable):
glibc-2.14-5.x86_64


How reproducible:

don't know, I'm not going to downgrade and upgrade glibc again

Steps to Reproduce:
1. yum update glibc*
  
Actual results:

# yum update glibc*
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.14-4 will be updated
---> Package glibc.x86_64 0:2.14-4 will be updated
---> Package glibc.i686 0:2.14-5 will be an update
---> Package glibc.x86_64 0:2.14-5 will be an update
---> Package glibc-common.x86_64 0:2.14-4 will be updated
---> Package glibc-common.x86_64 0:2.14-5 will be an update
---> Package glibc-devel.i686 0:2.14-4 will be updated
---> Package glibc-devel.x86_64 0:2.14-4 will be updated
---> Package glibc-devel.i686 0:2.14-5 will be an update
---> Package glibc-devel.x86_64 0:2.14-5 will be an update
---> Package glibc-headers.x86_64 0:2.14-4 will be updated
---> Package glibc-headers.x86_64 0:2.14-5 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================
 Package                      Arch                  Version               Repository              Size
=======================================================================================================
Updating:
 glibc                        i686                  2.14-5                updates                3.8 M
 glibc                        x86_64                2.14-5                updates                3.3 M
 glibc-common                 x86_64                2.14-5                updates                 11 M
 glibc-devel                  i686                  2.14-5                updates                977 k
 glibc-devel                  x86_64                2.14-5                updates                976 k
 glibc-headers                x86_64                2.14-5                updates                597 k

Transaction Summary
=======================================================================================================
Upgrade       6 Package(s)

Total download size: 21 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Download delta size: 12 M
(1/6): glibc-2.14-4_2.14-5.i686.drpm                                            | 871 kB     00:01     
(2/6): glibc-2.14-4_2.14-5.x86_64.drpm                                          | 586 kB     00:00     
(3/6): glibc-common-2.14-4_2.14-5.x86_64.drpm                                   |  10 MB     00:13     
(4/6): glibc-devel-2.14-4_2.14-5.i686.drpm                                      | 158 kB     00:00     
(5/6): glibc-devel-2.14-4_2.14-5.x86_64.drpm                                    | 158 kB     00:00     
(6/6): glibc-headers-2.14-4_2.14-5.x86_64.drpm                                  | 206 kB     00:00     
Finishing rebuild of rpms, from deltarpms
<delta rebuild>                                                                 |  21 MB     00:19     
Presto reduced the update size by 41% (from 21 M to 12 M).
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : glibc-2.14-5.x86_64                                                                1/12 
Non-fatal POSTIN scriptlet failure in rpm package glibc-2.14-5.x86_64
/usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
warning: %post(glibc-2.14-5.x86_64) scriptlet failed, exit status 1
  Updating   : glibc-common-2.14-5.x86_64                                                         2/12 
  Updating   : glibc-headers-2.14-5.x86_64                                                        3/12 
  Updating   : glibc-2.14-5.i686                                                                  4/12 
  Updating   : glibc-devel-2.14-5.i686                                                            5/12 
  Updating   : glibc-devel-2.14-5.x86_64                                                          6/12 
  Cleanup    : glibc-devel-2.14-4                                                                 7/12 
  Cleanup    : glibc-devel-2.14-4                                                                 8/12 
  Cleanup    : glibc-2.14-4                                                                       9/12 
  Cleanup    : glibc-headers-2.14-4.x86_64                                                       10/12 
  Cleanup    : glibc-2.14-4                                                                      11/12 
  Cleanup    : glibc-common-2.14-4.x86_64                                                        12/12 

Updated:
  glibc.i686 0:2.14-5             glibc.x86_64 0:2.14-5             glibc-common.x86_64 0:2.14-5       
  glibc-devel.i686 0:2.14-5       glibc-devel.x86_64 0:2.14-5       glibc-headers.x86_64 0:2.14-5      

Complete!


Expected results:

Updates cleanly

Comment 1 Andreas Schwab 2011-08-15 07:28:55 UTC

*** This bug has been marked as a duplicate of bug 698198 ***


Note You need to log in before you can comment on or make changes to this bug.