Bug 698198 - FIXED_IN_GIT: systemd reexec needs to be synchronous
Summary: FIXED_IN_GIT: systemd reexec needs to be synchronous
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 702357 702377 708683 711399 716597 716736 716944 730578 731953 786934 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-20 12:31 UTC by Richard W.M. Jones
Modified: 2012-03-11 19:02 UTC (History)
34 users (show)

Fixed In Version: systemd-26-10.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 17:07:46 UTC


Attachments (Terms of Use)
/var/log/messages during update (5.65 KB, text/plain)
2011-04-28 07:30 UTC, Richard W.M. Jones
no flags Details
/var/log/messages during glibc update (3.52 KB, text/plain)
2011-06-25 11:42 UTC, igory7lr
no flags Details

Description Richard W.M. Jones 2011-04-20 12:31:45 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Richard W.M. Jones 2011-04-20 12:32:55 UTC
Sorry, pressed the "enter" key at the wrong time.

This is a non-fatal error, but you'll get it if you install
F15 beta, then upgrade glibc in the ordinary way.  It's probably
not important, but I thought I would mention it anyway in case
it is a symptom of something bad going on underneath.

Non-fatal POSTIN scriptlet failure in rpm package glibc-2.13.90-9.x86_64
/usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
warning: %post(glibc-2.13.90-9.x86_64) scriptlet failed, exit status 1

Comment 2 Lennart Poettering 2011-04-27 00:38:50 UTC
What's the /sbin/service line that is triggering this? Any more output on this?

On my machine there is no /usr/sbin/glibc_post_upgrade?

Comment 3 Richard W.M. Jones 2011-04-27 07:36:16 UTC
/usr/sbin/glibc_post_upgrade.{i686,x86_64} are static binaries.

I had a look at the code for this binary and the only reference
to /sbin/service is this:

  /* Check if we can safely condrestart sshd.  */
  if (access ("/sbin/service", X_OK) == 0
      && access ("/usr/sbin/sshd", X_OK) == 0
      && access ("/etc/rc.d/init.d/sshd", X_OK) == 0
      && access ("/bin/bash", X_OK) == 0)
    {
      if (check_elf ("/usr/sbin/sshd"))
        verbose_exec (-121, "/sbin/service", "/sbin/service", "sshd", "condrestart");
    }

Comment 4 Jakub Jelinek 2011-04-27 07:45:09 UTC
I think this is a dup of some other bug, don't remember the bug number though.
The problem is that /sbin/service <servicename> condrestart
must exit with zero exit status both when the service has been running and has been successfully restarted, or when it has not been running (that's why it is condrestart, conditional restart).

Comment 5 Lennart Poettering 2011-04-27 15:03:55 UTC
But condrestart should work like that already since a while. The other bug was closed.

And verifying this manually, this works completely fine here.

# systemctl stop sshd.service
# systemctl condrestart sshd.service ; echo $?
0
# service sshd condrestart ; echo $?
Restarting sshd (via systemctl):                           [  OK  ]
0
# systemctl start sshd.service
# systemctl condrestart sshd.service ; echo $?
0
# service sshd condrestart ; echo $?
Restarting sshd (via systemctl):                           [  OK  ]
0

So condrestart returns 0 both when sshd is running and when it is not. As it should be.

No idea what is going on here. Richard, is there any other output generated when this happens?

Comment 6 Richard W.M. Jones 2011-04-27 15:22:26 UTC
Just the output shown, apart from the usual yum/rpm output
obviously.

Also on this machine 'service sshd condrestart' appears
to work OK:

$ sudo service sshd condrestart ; echo $?
Restarting sshd (via systemctl):                           [  OK  ]
0
$ sudo service sshd stop ; echo $?
Stopping sshd (via systemctl):                             [  OK  ]
0
$ sudo service sshd condrestart ; echo $?
Restarting sshd (via systemctl):                           [  OK  ]
0

Comment 7 Lennart Poettering 2011-04-28 03:24:59 UTC
Any output in syslog when this happens?

Comment 8 Richard W.M. Jones 2011-04-28 07:30:18 UTC
These are messages from around the same time.

/var/log/yum.log:

Apr 20 13:29:47 Updated: glibc-2.13.90-9.x86_64
Apr 20 13:30:01 Updated: glibc-common-2.13.90-9.x86_64

/var/log/messages:

[I will attach it as it's large]

Nothing else in other logs that looks relevant, but here is the
complete list of log files in case you want me to fish out
one of them:

drwxr-xr-x. 16 root root   4096 Apr 20 13:12 .
drwxr-xr-x. 18 root root   4096 Apr 20 12:39 ..
drwxr-xr-x.  2 root root   4096 Apr 20 13:10 ConsoleKit
-rw-r--r--.  1 root root  28022 Apr 20 13:36 Xorg.0.log
-rw-r--r--.  1 root root  28022 Apr 20 13:11 Xorg.9.log
drwxr-xr-x.  2 root root   4096 Apr 20 12:58 anaconda
drwxr-x---.  2 root root   4096 Apr 20 13:10 audit
drwxr-xr-x.  2  494  491   4096 Feb  8 07:27 bittorrent
-rw-r--r--.  1 root root   2150 Apr 20 13:10 boot.log
-rw-------.  1 root   22    384 Apr 20 13:11 btmp
-rw-r--r--.  1 root root     92 Apr 20 13:10 cron
drwxr-xr-x.  2 lp   sys    4096 Feb 25 13:38 cups
-rw-r--r--.  1 root root  93818 Apr 20 12:58 dracut.log
drwxrwx--T.  2 root   42   4096 Apr 20 13:11 gdm
-rw-r--r--.  1 root root 146292 Apr 20 13:30 lastlog
drwxr-xr-x.  2 root root   4096 Apr 20 12:34 mail
-rw-------.  1 root root    540 Apr 20 13:10 maillog
-rw-------.  1 root root  98739 Apr 20 13:36 messages
drwxr-xr-x.  2   38   38   4096 Feb  9 01:56 ntpstats
-rw-rw-r--.  1 root root      0 Apr 20 13:11 pm-powersave.log
drwx------.  2 root root   4096 Feb  9 16:30 ppp
drwxr-xr-x.  2 root root   4096 Nov 23 23:39 prelink
drwx------.  3 root root   4096 Apr 20 11:06 samba
-rw-------.  1 root root   3485 Apr 20 13:36 secure
drwxr-xr-x.  2 root root   4096 Mar  1 16:06 setroubleshoot
drwx------.  2 root root   4096 Mar 16 03:31 speech-dispatcher
-rw-------.  1 root root      0 Apr 20 11:03 spooler
drwxr-x---.  2 root root   4096 Mar 24 19:38 sssd
-rw-------.  1 root root      0 Apr 20 10:15 tallylog
-rw-rw-r--.  1 root   22   7680 Apr 20 13:36 wtmp
-rw-------.  1 root root   1826 Apr 20 13:34 yum.log

Comment 9 Richard W.M. Jones 2011-04-28 07:30:50 UTC
Created attachment 495430 [details]
/var/log/messages during update

Comment 10 Lennart Poettering 2011-04-28 15:13:14 UTC
Ah, here's my guess what is going on: glibc asks systemd to reexec and quickly after that asks it to restart sshd. The reexec is async, and the sshd restart might be issued at a time where systemd isn't responsive to requests yet.

Jakub, am I assuming right that this upgrade tool sends SIGTERM to PID 1, and afterwards restarts sshd?

To fix this we'd have to make the reexec synchronours. That's everything but trivial... Urks.

Comment 11 Richard W.M. Jones 2011-04-28 15:20:27 UTC
Indeed it is the case that the call to telinit immediately
precedes the call to service condrestart.  The exact code is:

  if (check_elf ("/proc/1/exe"))
    verbose_exec (116, "/sbin/telinit", "/sbin/telinit", "u");

  /* Check if we can safely condrestart sshd.  */
  if (access ("/sbin/service", X_OK) == 0
      && access ("/usr/sbin/sshd", X_OK) == 0
      && access ("/etc/rc.d/init.d/sshd", X_OK) == 0
      && access ("/bin/bash", X_OK) == 0)
    {
      if (check_elf ("/usr/sbin/sshd"))
        verbose_exec (-121, "/sbin/service", "/sbin/service", "sshd", "condrestart");
    }

Comment 12 Jakub Jelinek 2011-04-28 15:21:22 UTC
Yeah, glibc_post_upgrade spawns /sbin/telinit u too (the reason for that is to avoid unclean shut downs and make sure init uses the newly installed libc).

Comment 13 Lennart Poettering 2011-04-28 20:10:03 UTC
OK, found a nice way to make reeexecutions synchronous. "telinit u" will know wait until the new systemd is fully up before returning. This should fix the bug.

Comment 14 Fedora Update System 2011-04-30 02:57:55 UTC
systemd-26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-26-1.fc15

Comment 15 Fedora Update System 2011-05-01 03:29:02 UTC
systemd-26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Dong Chen 2011-05-04 14:14:07 UTC
I had update systemd-26-1, but problem isn't solved , and update to glibc-2.13.90-10, the same error exist :
  Updating   : glibc-2.13.90-10.x86_64                                                                            2/12 
Non-fatal POSTIN scriptlet failure in rpm package glibc-2.13.90-10.x86_64
/usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
warning: %post(glibc-2.13.90-10.x86_64) scriptlet failed, exit status 1

Comment 17 Andreas Schwab 2011-05-05 12:56:00 UTC
*** Bug 702357 has been marked as a duplicate of this bug. ***

Comment 18 Stijn Hoop 2011-05-05 13:18:55 UTC
Interesting that bugzilla did not find this bug while searching for the exact error. Oh well. In my case I got systemd-26-1 in the same upgrade as glibc-2.13.90-10 so I can only confirm the fix after yet another glibc upgrade. Or is it safe to downgrade only glibc? (seems like asking for trouble).

Comment 19 Andreas Schwab 2011-05-05 14:06:16 UTC
*** Bug 702377 has been marked as a duplicate of this bug. ***

Comment 20 Michal Schmidt 2011-05-13 13:20:16 UTC
Reopening. The bug is still present in systemd-26-1.fc15.

# telinit u; service sshd condrestart; echo $?
Restarting sshd (via systemctl):  Failed to get D-Bus connection: Connection terminated during authentication.
                                                           [SELHALO]
1

But this works:

# systemctl daemon-reexec; service sshd condrestart; echo $?
Restarting sshd (via systemctl):                           [  OK  ]
0

This contradicts what "man telinit" says:

       u, U
           Serialize state, reexecute daemon and deserialize state again.
           This is equivalent to systemctl daemon-reexec.

Comment 21 Lennart Poettering 2011-05-15 13:24:19 UTC
Oh, dang.

I far "telinit u" is probaly not fixable, since the old SysV telinit fifo is used in a fire-and-forget way. i.e. the command just writes a blob to the fifo and quits. There is not back channel that could be used to return the information about completion back.

Comment 22 Lennart Poettering 2011-05-15 13:24:57 UTC
What we can do probably is ensure that telinit u always uses dbus to communicate instead of /dev/initctl

Comment 23 Jakub Jelinek 2011-05-19 12:14:52 UTC
Isn't a bigger problem that during restarting of systemd service fails?
I mean, even if you make telinit u synchronous instead of asynchronous, if somebody simultaneously with telinit u calls service <someservice> condrestart,
it will fail, instead of waiting till systemd is back up and handles that request.
Sure, there should be some timeout to avoid waiting forever...

Comment 24 Andreas Schwab 2011-05-30 07:16:29 UTC
*** Bug 708683 has been marked as a duplicate of this bug. ***

Comment 25 Andreas Schwab 2011-06-07 12:19:42 UTC
*** Bug 711399 has been marked as a duplicate of this bug. ***

Comment 26 udo 2011-06-25 09:26:12 UTC
# yum history info 511
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Transaction ID : 511
Begin time     : Sat Jun 25 07:21:28 2011
Begin rpmdb    : 2160:036f87d0abf0cb0bb989d2530af7aa979bd24d0e
End time       :            07:24:27 2011 (179 seconds)
End rpmdb      : 2160:083f4c75662a0ad91ba64e77139bb8f3ef34a968
User           : Udo <udo>
Return-Code    : Success
Command Line   : update
Transaction performed with:
    Installed     rpm-4.9.0-9.fc15.x86_64
    Installed     yum-3.2.29-6.fc15.noarch
    Installed     yum-presto-0.6.2-3.fc15.noarch
Packages Altered:
    Updated autofs-1:5.0.5-35.fc15.x86_64
    Update         1:5.0.5-38.fc15.x86_64
    Updated device-mapper-1.02.63-2.fc14.x86_64
    Update                1.02.63-3.fc15.x86_64
    Updated device-mapper-devel-1.02.63-2.fc14.x86_64
    Update                      1.02.63-3.fc15.x86_64
    Updated device-mapper-event-1.02.63-2.fc14.x86_64
    Update                      1.02.63-3.fc15.x86_64
    Updated device-mapper-event-libs-1.02.63-2.fc14.x86_64
    Update                           1.02.63-3.fc15.x86_64
    Updated device-mapper-libs-1.02.63-2.fc14.x86_64
    Update                     1.02.63-3.fc15.x86_64
    Updated firefox-4.0.1-2.fc15.x86_64
    Update          5.0-1.fc15.x86_64
    Updated gimp-2:2.6.11-15.fc15.x86_64
    Update       2:2.6.11-16.fc15.x86_64
    Updated gimp-devel-2:2.6.11-15.fc15.x86_64
    Update             2:2.6.11-16.fc15.x86_64
    Updated gimp-devel-tools-2:2.6.11-15.fc15.x86_64
    Update                   2:2.6.11-16.fc15.x86_64
    Updated gimp-help-browser-2:2.6.11-15.fc15.x86_64
    Update                    2:2.6.11-16.fc15.x86_64
    Updated gimp-libs-2:2.6.11-15.fc15.x86_64
    Update            2:2.6.11-16.fc15.x86_64
    Updated gjs-0.7.14-3.fc15.x86_64
    Update      0.7.14-6.fc15.x86_64
    Updated glibc-2.14-2.i686
    Updated glibc-2.14-2.x86_64
    Update        2.14-3.i686
    Update        2.14-3.x86_64
    Updated glibc-common-2.14-2.x86_64
    Update               2.14-3.x86_64
    Updated glibc-devel-2.14-2.x86_64
    Update              2.14-3.x86_64
    Updated glibc-headers-2.14-2.x86_64
    Update                2.14-3.x86_64
    Updated gnome-python2-extras-2.25.3-31.fc15.x86_64
    Update                       2.25.3-32.fc15.x86_64
    Updated gnome-python2-gtkhtml2-2.25.3-31.fc15.x86_64
    Update                         2.25.3-32.fc15.x86_64
    Updated gnome-python2-gtkspell-2.25.3-31.fc15.x86_64
    Update                         2.25.3-32.fc15.x86_64
    Updated gnome-python2-libegg-2.25.3-31.fc15.x86_64
    Update                       2.25.3-32.fc15.x86_64
    Updated gnome-shell-3.0.2-1.fc15.x86_64
    Update              3.0.2-3.fc15.x86_64
    Updated js-1:1.8.5-4.fc15.x86_64
    Update     1:1.8.5-6.fc15.x86_64
    Updated libreport-2.0.3-1.fc15.x86_64
    Update            2.0.4-1.fc15.x86_64
    Updated libreport-gtk-2.0.3-1.fc15.x86_64
    Update                2.0.4-1.fc15.x86_64
    Updated libva-1.0.12-1.fc15.x86_64
    Update        1.0.13-2.fc15.x86_64
    Updated lvm2-2.02.84-2.fc14.x86_64
    Update       2.02.84-3.fc15.x86_64
    Updated lvm2-libs-2.02.84-2.fc14.x86_64
    Update            2.02.84-3.fc15.x86_64
    Updated motion-3.2.12-1.fc14.x86_64
    Update         3.3.0-trunkREV528.fc15.x86_64
    Updated nscd-2.14-2.x86_64
    Update       2.14-3.x86_64
    Updated python-xlib-0.15-0.4.rc1.fc15.noarch
    Update              0.15-0.5.rc1.fc15.noarch
    Updated vcdimager-0.7.23-13.fc13.1.x86_64
    Update            0.7.24-1.fc15.x86_64
    Updated vcdimager-libs-0.7.23-13.fc13.1.x86_64
    Update                 0.7.24-1.fc15.x86_64
    Updated xulrunner-2.0.1-1.fc15.x86_64
    Update            5.0-2.fc15.x86_64
Scriptlet output:
   1 /usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
   2 warning: %post(glibc-2.14-3.x86_64) scriptlet failed, exit status 1
   3 warning: /etc/motion/motion.conf created as /etc/motion/motion.conf.rpmnew
history info
# rpm -q systemd
systemd-26-4.fc15.x86_64

Comment 27 igory7lr 2011-06-25 11:42:17 UTC
Created attachment 509892 [details]
/var/log/messages during glibc update

Hello. After today update of glibc I got same warning:

Non-fatal POSTIN scriptlet failure in rpm package glibc-2.14-3.x86_64
/usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
warning: %post(glibc-2.14-3.x86_64) scriptlet failed, exit status 1


I hope you find my /var/log/mesasges snippet useful.

Comment 28 Andreas Schwab 2011-06-27 07:50:50 UTC
*** Bug 716597 has been marked as a duplicate of this bug. ***

Comment 29 Andreas Schwab 2011-06-27 07:51:33 UTC
*** Bug 716736 has been marked as a duplicate of this bug. ***

Comment 30 an0nym 2011-06-27 10:11:07 UTC
Got the same problem as in comment 27 recently. 

While the bug is being fixed, can anyone explain what the error during update meant (what was done and what wasn't?) and how can we (should we?) fix it by hand instead of waiting for an update?

Comment 31 Andreas Schwab 2011-06-27 14:27:33 UTC
*** Bug 716944 has been marked as a duplicate of this bug. ***

Comment 32 Fred New 2011-06-27 14:47:47 UTC
an0nym: The post-installation scriptlet just tries to restart sshd.  You can restart it manually with
     service sshd restart
(I haven't taught myself the systemctl syntax, yet.)

Comment 33 ramez hanna 2011-07-13 23:38:27 UTC
i am seeing an issue that i think is same 
i use yum to create a chrot of fedora
so basically it runs 
yum --installroot $INSTALL_ROOT -y --nogpgcheck yum initscripts passwd rsyslog vim-minimal dhclient chkconfig rootfiles policycoreutils

then it stops with this log

  Installing : glibc-common-2.14-4.x86_64                                                                                                              12/156
Non-fatal POSTIN scriptlet failure in rpm package glibc-common-2.14-4.x86_64
Non-fatal <unknown> scriptlet failure in rpm package glibc-common-2.14-4.x86_64
lxc-fedora.in: line 100:  1278 Segmentation fault      $YUM install $PKG_LIST

Comment 34 clonnerz 2011-07-20 20:14:35 UTC
[root@xanax var]# rpm -qa systemd
systemd-26-8.fc15.x86_64
[root@xanax var]# uname -a
Linux xanax 2.6.38.8-35.fc15.x86_64 #1 SMP Wed Jul 6 13:58:54 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
[root@xanax var]# 


Date: Wed, 20 Jul 2011 15:45:01 -0400
From: Cron Daemon <root@xanax>
To: root@xanax
Subject: Cron <root@xanax> /bin/systemctl restart dhcpd.service ; /bin/systemctl reload-or-try-restart shorewall.service 2>&1 >
    /dev/null

Failed to get D-Bus connection: Connection terminated during authentication.
Failed to get D-Bus connection: Connection terminated during authentication.


Date: Wed, 20 Jul 2011 15:00:01 -0400
From: Cron Daemon <root@xanax>
To: root@xanax
Subject: Cron <root@xanax> /sbin/service snortd restart 2>&1 > /dev/null

Failed to get D-Bus connection: Connection terminated during authentication.



root@xanax var]# date
Wed Jul 20 16:05:10 EDT 2011
[root@xanax var]# grep -i d-bus /var/log/messages
Jul 18 23:21:33 xanax systemd-initctl[9126]: Failed to get D-Bus connection: Connection terminated during authentication.
Jul 18 23:21:33 xanax systemd-initctl[9128]: Failed to get D-Bus connection: Connection terminated during authentication.
Jul 18 23:21:33 xanax systemd-initctl[9130]: Failed to get D-Bus connection: Connection terminated during authentication.
Jul 18 23:21:33 xanax systemd-initctl[9132]: Failed to get D-Bus connection: Connection terminated during authentication.
Jul 18 23:21:33 xanax systemd-initctl[9134]: Failed to get D-Bus connection: Connection terminated during authentication.
Jul 18 23:21:33 xanax systemd-initctl[9136]: Failed to get D-Bus connection: Connection terminated during authentication.
[root@xanax var]# 
[root@xanax var]# file /var/run/dbus/system_bus_socket
/var/run/dbus/system_bus_socket: socket
[root@xanax var]# ls -las /var/run/dbus/system_bus_socket
0 srwxrwxrwx 1 root root 0 Jul 18 23:32 /var/run/dbus/system_bus_socket


[root@xanax var]# kill -1 1213
[root@xanax var]# lsof | grep /var/run/dbus/system_bus_socket
systemd       1                  root   17u     unix 0xffff880037ab8d00       0t0      14784 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus    3u     unix 0xffff880037ab8d00       0t0      14784 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus    8u     unix 0xffff8800b73163c0       0t0      17997 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus    9u     unix 0xffff880037abb740       0t0      17998 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus   10u     unix 0xffff8800b7316080       0t0      17999 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus   11u     unix 0xffff8800b5d67a80       0t0      22032 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus   12u     unix 0xffff880037202d80       0t0      21141 /var/run/dbus/system_bus_socket
dbus-daem  1213                  dbus   14u     unix 0xffff88000e412a40       0t0    1031652 /var/run/dbus/system_bus_socket
[root@xanax var]# tail -f /var/log/messages &
[1] 19012
[root@xanax var]# Jul 20 16:00:07 xanax xenconsoled: Failed to contact xenstore (No such file or directory).  Is it running?
Jul 20 16:00:12 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:00:12 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:03:19 xanax rsyslogd-2177: imuxsock lost 112 messages from pid 18826 due to rate-limiting
Jul 20 16:05:01 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:05:01 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:05:07 xanax xenconsoled: Failed to contact xenstore (No such file or directory).  Is it running?
Jul 20 16:05:12 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:05:12 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:08:58 xanax dbus-daemon: [system] Reloaded configuration

[root@xanax var]# ps auwwJul 20 16:10:01 xanax systemd[1]: Too many concurrent connections.
Jul 20 16:10:01 xanax systemd[1]: Too many concurrent connections.
wx | grep Jul 20 16:10:06 xanax xenconsoled: Failed to contact xenstore (No such file or directory).  Is it running?
18826
root     19076  0.0  0.0 109100   832 pts/0    S+   16:10   0:00 grep --color=auto 18826
You have new mail in /var/spool/mail/root
[root@xanax var]# Jul 20 16:10:12 xanax systemd[1]: Too many concurrent connections.

[root@xanax var]# chkconfig xenconsoled off
Jul 20 16:10:58 xanax systemd[1]: Too many concurrent connections.
[root@xanax var]# systemctl stop xenconsoled.service
Failed to get D-Bus connection: Connection terminated during authentication.
Jul 20 16:11:11 xanax systemd[1]: Too many concurrent connections.
You have new mail in /var/spool/mail/root
[root@xanax var]# service gpm restart
Restarting gpm (via systemctl):  Failed to get D-Bus connection: Connection terminated during authentication.
Jul 20 16:11:57 xanax systemd[1]: Too many concurrent connections.
                                                           [FAILED]
[root@xanax var]# service samba restart
samba: unrecognized service
[root@xanax var]# service smb restart
Restarting smb (via systemctl):  Jul 20 16:12:15 xanax systemd[1]: Too many concurrent connections.
Failed to get D-Bus connection: Connection terminated during authentication.
                                                           [FAILED]
You have mail in /var/spool/mail/root
[root@xanax var]#

Comment 35 Andrei ILIE 2011-07-22 16:36:04 UTC
Hello there,

  I subscribe to this bug: just installed stable F15 and performed a yum update and this is what I got:

Non-fatal POSTIN scriptlet failure in rpm package glibc-2.14-4.x86_64
/usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
warning: %post(glibc-2.14-4.x86_64) scriptlet failed, exit status 1


----------------------------------------------------

andrei@cofee:~$ yum -C list systemd
Installed Packages
systemd.x86_64 version = 26-8.fc15

----------------------------------------------------


PS: Pretty hard to find your installed systemd version :)

  andrei@cofee:~$ systemd -v
    systemd: invalid option -- 'v'
    Unknown option code ?

  andrei@cofee:~$ systemd --version
    systemd: unrecognized option '--version'
    Unknown option code ?

Comment 36 Andreas Schwab 2011-08-15 07:28:55 UTC
*** Bug 730578 has been marked as a duplicate of this bug. ***

Comment 37 Andreas Schwab 2011-08-19 09:33:06 UTC
*** Bug 731953 has been marked as a duplicate of this bug. ***

Comment 38 Lennart Poettering 2011-08-31 01:34:13 UTC
Urks, this was actually a trivial mistake: "telinit u" first did the fully synchronous reexecution of PID 1, but then repeated this asynchronously via sending SIGTERM to PID1 which was intended as fallback only but got executed unconditionally. Fixed now in git.

Comment 39 Fedora Update System 2011-09-01 00:34:34 UTC
systemd-35-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/systemd-35-1.fc16

Comment 40 Fedora Update System 2011-09-01 19:02:37 UTC
Package systemd-35-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-35-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/systemd-35-1.fc16
then log in and leave karma (feedback).

Comment 41 Eddie Lania 2011-09-01 19:13:13 UTC
Will there be following an update for F15 as well shortly?

Comment 42 Fedora Update System 2011-09-09 17:06:58 UTC
systemd-35-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2011-09-25 23:29:57 UTC
systemd-26-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-26-10.fc15

Comment 44 Fedora Update System 2011-10-05 03:53:11 UTC
systemd-26-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 45 Jeff Law 2012-02-07 21:09:22 UTC
*** Bug 786934 has been marked as a duplicate of this bug. ***

Comment 46 rambler8 2012-03-11 19:02:30 UTC
It looks like this is still a problem on Fedora 15

#rpm -q systemd
systemd-26-16.fc15.i686


Updating   : glibc-2.14.1-6.i686 
Non-fatal POSTIN scriptlet failure in rpm package glibc-2.14.1-6.i686
/usr/sbin/glibc_post_upgrade: While trying to execute /sbin/service child exited with exit code 1
warning: %post(glibc-2.14.1-6.i686) scriptlet failed, exit status 1


Note You need to log in before you can comment on or make changes to this bug.