Bug 73060 - Norwegian spellchecker
Norwegian spellchecker
Status: CLOSED DUPLICATE of bug 108720
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 05:50 EDT by Toralf
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 09:05:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iaff2myaff.perl (Source2) (2.26 KB, text/plain)
2002-08-30 06:23 EDT, Toralf
no flags Details
ispell-3.2.06.no.patch (Patch0) (6.40 KB, patch)
2002-08-30 06:24 EDT, Toralf
no flags Details | Diff
ispell-norsk.myspell.patch (Patch1) (3.83 KB, patch)
2002-08-30 06:25 EDT, Toralf
no flags Details | Diff
The spec (2.77 KB, text/plain)
2002-08-30 06:44 EDT, Toralf
no flags Details
/usr/libexec/myspell/updateList - dictionary.lst update script (218 bytes, text/plain)
2002-08-30 06:46 EDT, Toralf
no flags Details
Bokmel dictionary (344.85 KB, application/zip)
2002-08-30 15:03 EDT, Toralf
no flags Details
Nynorsk dictionary (449.83 KB, application/zip)
2002-08-30 15:04 EDT, Toralf
no flags Details
Updated dictionaries (1022.85 KB, application/zip)
2002-11-21 10:46 EST, Toralf
no flags Details
Updated SPEC file (1.61 KB, text/plain)
2003-10-06 07:36 EDT, Toralf
no flags Details
Updated "Patch1" (12.15 KB, text/plain)
2003-10-06 07:38 EDT, Toralf
no flags Details
Dictionary update (info only) (448 bytes, text/plain)
2003-10-06 07:43 EDT, Toralf
no flags Details

  None (edit)
Description Toralf 2002-08-30 05:50:01 EDT
Support for Norwegian in the spellchecer would be nice. In fact, I have an RPM
for this already, which is based on the ispell dictionaries at
http://www.uio.no/~runekl/dictionary.html; the .spec file will be attached shortly.

Note:
1) The spec will actually build ispell, since special patches are needed and
because Red Hat has no default ispell package.
2) Source 0 and 1 should be familiar to you, the rest will be attached.
3) I usally create a file dictionary_<lang code>_.lst for each dictionary and
generate global dictionary.lst based in info in these. I have a special script,
"updateList", for that purpose. It is included in a different package on my
setup, but will also be attached here.
4) The dictionaries are installed on directory /usr/share/myspell by default. I
have moved everything there and created the appropriate link for OOo dictionary
localtion to get a somewhat cleaner setup. The behaviour may, however, be
changed by redefining macro "dictdir".
Comment 1 Toralf 2002-08-30 06:23:14 EDT
Created attachment 73929 [details]
iaff2myaff.perl (Source2)
Comment 2 Toralf 2002-08-30 06:24:12 EDT
Created attachment 73930 [details]
ispell-3.2.06.no.patch (Patch0)
Comment 3 Toralf 2002-08-30 06:25:22 EDT
Created attachment 73931 [details]
ispell-norsk.myspell.patch (Patch1)
Comment 4 Toralf 2002-08-30 06:44:51 EDT
Created attachment 73936 [details]
The spec
Comment 5 Toralf 2002-08-30 06:46:19 EDT
Created attachment 73937 [details]
/usr/libexec/myspell/updateList - dictionary.lst update script
Comment 6 Toralf 2002-08-30 06:52:59 EDT
There is one quite serious problem with all this: The dictionary files are
actually quite hard to build; the process is *SLOW* and commands may crash
during the process without 'make' noticing it (hence the core dump test). This
has nothing to do with my "MySpell" additions, it is a problem with
ispell-norsk. Perhaps some of you lot know a way around it?
Comment 7 Jakub Jelinek 2002-08-30 09:41:23 EDT
Can you please instead attach a .zip file with n[bn]_NO.{aff,dic} and say a
README with credits and how you have made it (and also contact with it
Kevin Hendricks, see
http://whiteboard.openoffice.org/lingucomponent/download_dictionary.html
so that everyone can download it)?
I really don't want to include ispell source etc. just to build these files
(especially this late).
Thanks.
Comment 8 Toralf 2002-08-30 10:05:41 EDT
Hmmm. I just might (I've been in touch with Kevin Hendricks earlier), although I
really think RPMs should be based on the ultimate source, not generated files.

Apart from that, I'm a bit confused about the current state of spell checkers in
general. Does aspell have a maintaner now? And will aspell/ispell/myspell ever
be integrated?
Comment 9 Jakub Jelinek 2002-08-30 11:02:06 EDT
Well, as all the other spell dicts in OOo src.rpm are not generated and especially
when we don't ship ispell, this looks like too much trouble.
So, if you manage to attach here the .zip file today, it can make it into
OOo for this release, otherwise I'm afraid it will have to wait.

As for the state of spelling checkers, I really don't know, teg@redhat.com
might tell you more.
Comment 10 Toralf 2002-08-30 15:03:19 EDT
Created attachment 74005 [details]
Bokmel dictionary
Comment 11 Toralf 2002-08-30 15:04:38 EDT
Created attachment 74006 [details]
Nynorsk dictionary
Comment 12 Toralf 2002-08-30 15:10:58 EDT
There now. I actually rushed back to my office to be able to submit these, so I
hope they'll be included. Note that description for nb_NO.zip should read
"Bokmel dictionary" - apparently non-ASCII characters won't be accepted on
attachment description input (now, I'm wondering if they will be here...)
Comment 13 Toralf 2002-08-30 15:13:50 EDT
No. Same result. It's supposed to be "Bokmaal" written with an "aring", but
maybe  you gathered that already.
Comment 14 Toralf 2002-11-21 10:46:06 EST
Created attachment 85909 [details]
Updated dictionaries
Comment 15 Toralf 2002-11-21 10:48:11 EST
Some words, notably "i" and "e" (single-letter word "aring") are missing from
original dictionarie, possibly due to bugs in ispell-norsk. This new version is
hopefully better.
Comment 16 Toralf 2003-10-06 07:31:10 EDT
I have an updated version of the dictioaries that turns out to be too large to
attach here. It should soon arrive on OOo dictionary download page, however.

Something I've been wondering about: Is there any particular reasons why you
chose "no_NO", as opposed to "nb_NO", in the filename for when packaging the
"bookmaal" dictionary for your source rpm?
Comment 17 Toralf 2003-10-06 07:36:11 EDT
Created attachment 94945 [details]
Updated SPEC file

Note that I'm also still using RPM to generate the dictionaries. However, I'm
now viewing it solely as a convenent way of packaging all the sources and
commands needed to build the "final" dictionary sources, rather than a way of
installing the dictionaries. In other words, RPM will simply create no_NO.zip,
not install it on the target location.
Comment 18 Toralf 2003-10-06 07:38:50 EDT
Created attachment 94946 [details]
Updated "Patch1"
Comment 19 Toralf 2003-10-06 07:43:01 EDT
Created attachment 94947 [details]
Dictionary update (info only)

My notes on the updated dictionaries. The actual files should soon be
downlodable from

http://distribution.openoffice.org/cdrom/dictionaries/download_dictionary.html
Comment 20 Dan Williams 2004-02-04 22:11:45 EST
generalizing this bug...

*** This bug has been marked as a duplicate of 108720 ***
Comment 21 Caolan McNamara 2005-04-28 09:05:49 EDT
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.