Bug 730878 - RFE: Colour highlights of tags should stay visible when editing entry
Summary: RFE: Colour highlights of tags should stay visible when editing entry
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Usability
Version: 1.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 2.0
Assignee: Patrick Huang
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
: 751675 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 05:29 UTC by Hedda Peters
Modified: 2012-11-07 06:19 UTC (History)
4 users (show)

Fixed In Version: 1.8.0-SNAPSHOT (20120920-1415)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 06:19:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 844820 None None None Never

Internal Links: 844820

Description Hedda Peters 2011-08-16 05:29:04 UTC
Description of problem:
Colour highlights of tags are only visible when entry is not active. When editing an entry, these highlights disappear

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Open the editor
2. Find an entry that contains tags - they will be highlighted in purple or red
3. Clicking into this entry for editing makes the highlights disappear in the translation, only to re-appear when saving the entry.
  
Actual results:
Highlights disappear when editing

Expected results:
Highlights should remain visible when editing

Additional info:

Comment 1 Sean Flanigan 2011-08-16 06:14:42 UTC
We used to use CodeMirror for syntax highlighting in the editor, but had to disable it because of some weird problems when it was used in our editor table and lack of time for debugging them.  We still use CodeMirror for the static highlighting, but we could look at getting it going again in the editor.

Comment 2 Sean Flanigan 2011-09-07 04:32:55 UTC
Assigning to Scrum product owner for prioritisation.

Comment 3 Patrick Huang 2012-09-03 03:56:21 UTC
*** Bug 751675 has been marked as a duplicate of this bug. ***

Comment 4 Patrick Huang 2012-09-18 01:21:49 UTC
committed as part of editor rewrite https://bugzilla.redhat.com/show_bug.cgi?id=844820

Comment 5 Ding-Yi Chen 2012-09-20 06:41:23 UTC
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20120920-1415)

Comment 6 Sean Flanigan 2012-11-07 06:19:11 UTC
Fix released in Zanata 2.0.


Note You need to log in before you can comment on or make changes to this bug.