Bug 730926 - system halts at reboot after install with vnc
system halts at reboot after install with vnc
Status: CLOSED DUPLICATE of bug 737118
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 738944 (view as bug list)
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-16 05:23 EDT by Hongqing Yang
Modified: 2011-09-21 06:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-21 06:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (16.27 KB, image/png)
2011-08-16 05:23 EDT, Hongqing Yang
no flags Details
screenshot (1.36 KB, image/png)
2011-08-16 05:23 EDT, Hongqing Yang
no flags Details
anaconda logs (380.00 KB, application/x-tar)
2011-08-16 05:29 EDT, Hongqing Yang
no flags Details
boot messages (29.49 KB, text/plain)
2011-09-20 02:27 EDT, Kamil Páral
no flags Details
boot messages with systemd debug (125.88 KB, text/plain)
2011-09-20 02:56 EDT, Kamil Páral
no flags Details

  None (edit)
Description Hongqing Yang 2011-08-16 05:23:04 EDT
Created attachment 518443 [details]
screenshot

Description of problem:
refer test case:https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_VNC_Vncconnect

reboot system after installation with vnc, the system halts, whatever enforcing=0 or not. i386 and x86_64 are both tested.


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. install system with vnc
2. reboot after installation
3.
  
Actual results:

system halts, whatever enforcing=0 or not

Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-08-16 05:23:35 EDT
Created attachment 518444 [details]
screenshot
Comment 2 Hongqing Yang 2011-08-16 05:29:53 EDT
Created attachment 518445 [details]
anaconda logs
Comment 3 Hongqing Yang 2011-08-17 01:43:25 EDT
reproduced on f16-alpha-rc5,  the it works well with minimal install
Comment 4 Hongqing Yang 2011-09-12 23:24:26 EDT
reproduced on f16-beta-tc2
Comment 5 Hongqing Yang 2011-09-16 00:58:34 EDT
reproduced on f16-beta-rc1
Comment 6 Adam Williamson 2011-09-19 21:43:38 EDT
why was this not proposed as a blocker bug? it seems to be one according to the alpha criteria.
Comment 7 Kamil Páral 2011-09-20 02:26:38 EDT
Reproduced with F16 Beta RC1 i686. Minimal install works, but default install doesn't boot. Proposing as blocker.

"In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account."
https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 8 Kamil Páral 2011-09-20 02:27:11 EDT
Created attachment 523957 [details]
boot messages
Comment 9 Adam Williamson 2011-09-20 02:33:16 EDT
kamil: the other criterion to cite is "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces " (Alpha) - the two together make this blocker, I think.
Comment 10 Kamil Páral 2011-09-20 02:56:52 EDT
Created attachment 523959 [details]
boot messages with systemd debug

adamw: Well, it _completed_ the installation, it just doesn't boot afterwards :-) I wasn't sure whether it covers that or not.

Attaching logs with systemd.log_level=debug. Heavy output warning!
Comment 11 Martin Gracik 2011-09-20 03:52:15 EDT
I think this is duplicate of bug #737118

Can you please retest with the latest release?
Comment 12 Kamil Páral 2011-09-20 05:07:39 EDT
(In reply to comment #11)
> I think this is duplicate of bug #737118

I just skimmed through the comments, but this bug seems to be happening also for runlevel 5, not just 3.

> Can you please retest with the latest release?

Latest release of anaconda? In that case we will probably have to wait for F16 Beta RC2.
Comment 13 Martin Gracik 2011-09-20 05:15:33 EDT
In the screenshot, one of the last messages is running /usr/bin/setup. That is run only in text-mode. So I suspect it's the same problem.

No need for latest anaconda, if what I'm saying is right, latest firstboot is enough, that is firstboot-16.4-1
Comment 14 Kamil Páral 2011-09-20 05:23:57 EDT
Do we have some compose ready that would include firstboot-16.4-1?
Comment 15 Martin Gracik 2011-09-20 06:16:12 EDT
I think you don't need a new compose, you just need a repo with the new firstboot package. But I'm not sure if it is anywhere yet.

The status on fedora updates is still pending...
Comment 16 Adam Williamson 2011-09-20 15:34:33 EDT
yeah, you only need a repo for the installer with firstboot in it. the new firstboot was just pushed to testing, so just installing with updates-testing selected might be enough if your mirror is up to date. otherwise, you can put a side repo up and point anaconda at it.
Comment 17 Hongqing Yang 2011-09-20 22:24:15 EDT
*** Bug 738944 has been marked as a duplicate of this bug. ***
Comment 18 Kamil Páral 2011-09-21 05:51:04 EDT
I have installed system over VNC using updates-testing including firstboot-16.4-1. The system boots. However, it boots only to runlevel 3 and I had to issue "init 5" to see firstboot and user session afterwards.

I think this bug can be closed as fixed and I'll file a separate bug report about the wrong default runlevel.
Comment 19 Martin Gracik 2011-09-21 06:03:12 EDT

*** This bug has been marked as a duplicate of bug 737118 ***

Note You need to log in before you can comment on or make changes to this bug.