Bug 731039 - Proprietary jdks 7 are not located properly by s-s-java
Summary: Proprietary jdks 7 are not located properly by s-s-java
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-switch-java
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: jiri vanek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 798565 798569
TreeView+ depends on / blocked
 
Reported: 2011-08-16 14:30 UTC by jiri vanek
Modified: 2012-02-29 09:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 798565 798569 (view as bug list)
Environment:
Last Closed: 2011-12-06 18:53:25 UTC


Attachments (Terms of Use)
proposed patch (7.24 KB, patch)
2011-08-16 14:45 UTC, jiri vanek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1744 normal SHIPPED_LIVE system-switch-java bug fix update 2011-12-06 01:01:50 UTC

Description jiri vanek 2011-08-16 14:30:02 UTC
Description of problem:
s-s-java can not recognize beta packages of ibm and oracle java 7


How reproducible:
always

Steps to Reproduce:
1. install ibm and (or) sun jdk 7, you can also install other jdks (ibm 4-6, oracle 6, openjdk 6,7, gcj 5....)
2. run alternatives --config java command
3. you will see eg:
  Selection    Command
-----------------------------------------------
   1           /usr/lib/jvm/jre-1.5.0-gcj/bin/java
   2           /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/java
   3           /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java
   4           /usr/lib/jvm/java-1.7.0-sun-1.7.0.0.x86_64/jre/bin/java

  
Actual results:
run system-switch-java, you will see eg:
jre-1.5.0-gcj
jre-1.6.0-openjdk.x86_64
jre-1.7.0-openjdk.x86_64

Expected results:
jre-1.5.0-gcj
jre-1.6.0-openjdk.x86_64
jre-1.7.0-openjdk.x86_64
java-1.7.0-sun-1.7.0.0.x86_64

Additional info:

This is caused by situatuion that proprietary jdks are linking their jre directly from alternatives  instead of jre link.

Comment 3 jiri vanek 2011-08-16 14:45:28 UTC
Created attachment 518506 [details]
proposed patch

This is proposed patch.
It also fix 725718, Sorry for not delivering them separately, but they are quite bound together.

Comment 11 errata-xmlrpc 2011-12-06 18:53:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1744.html

Comment 12 jiri vanek 2012-02-29 09:21:10 UTC
java-1.7.0-sun was renamed to java-1.7.0-oracle. I'm afraid it will need changes also in s-s-java


Note You need to log in before you can comment on or make changes to this bug.