Bug 731091 - Very slow redraw on modal windows and menus with icon size in options set to small
Very slow redraw on modal windows and menus with icon size in options set to ...
Status: CLOSED DUPLICATE of bug 734612
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 12:22 EDT by Paul F. Johnson
Modified: 2011-11-08 07:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-08 07:49:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2011-08-16 12:22:31 EDT
Description of problem:
There is a noticable slow-down in redraw speed in the current OOo (doesn't matter which component is used) when it comes to any modal boxes or menus. It is sometimes required to rapidly move the mouse over menu items et al to get them to show.

I have tried with and without hardware acceleration support ticked and it makes no difference.

Slow down is not desktop environment specific (happens on KDE and Gnome)

Version-Release number of selected component (if applicable):
libreoffice-writer-3.4.2.3-3.fc17.x86_64
kernel-3.1.0-0.rc1.git6.1.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start writer
2. Click on any menu
3.
  
Actual results:
Visible delay

Expected results:
Silky smooth as it always was

Additional info:
Using an nVidia graphics card
Comment 1 Caolan McNamara 2011-08-17 04:12:30 EDT
Hardware accel means "use cairo" and only affects the full-screen slideshow FWIW.

re menus and the like, I'm sure we didn't change anything there on the libreoffice side. So its possibly triggered by a change in something else. Boot the previous kernel ?, use previous X drivers ? anything in /var/log/X* logs ? /var/log/messages ?
Comment 2 Paul F. Johnson 2011-08-17 11:44:51 EDT
Given it is the *only* app I've notice slow down under the 3.x kernels on rawhide (most it's made no difference to). Can't see anything of not in messages or X* logs to make me suspect anything.

Slow down is on all components of OOo.
Comment 3 Caolan McNamara 2011-08-17 11:58:05 EDT
does it make any difference to roll back libreoffice to an older version. I'm having a hard time even guessing what it might be.
Comment 4 Paul F. Johnson 2011-08-19 09:04:15 EDT
Rather than go backwards, I cleared out my settings to see if I can break it again.

Simple answer is that if you change the icon size in options to small, the redraw is messed up. Change it back to automatic and it's fine again.
Comment 5 Caolan McNamara 2011-08-19 10:48:00 EDT
sounds kind of bizarre
Comment 6 Paul F. Johnson 2011-08-20 07:57:24 EDT
Yeah - it's not a killer, just annoying. Any ideas on the cause?
Comment 7 Paul F. Johnson 2011-08-30 17:56:32 EDT
It's gnome. Tried under xcfe and kde and everything is fine. Dunno why it was slow under KDE last time, it's running well now.

Gnome is being a resource hog now. Grrrr. Should I reassign this to gnome-desktop?

(Proof of the pudding, run any mono winform application under gnome and it lags - no problem under KDE)
Comment 8 Germano Massullo 2011-11-06 16:28:00 EST
On a T41 with Fedora 15 KDE 32bit, I have very slow transictions when writing inside cells in Calc.
Could you please tell me which start commands should I use to get debugging code that we can use here?
Comment 9 Caolan McNamara 2011-11-08 07:49:10 EST

*** This bug has been marked as a duplicate of bug 734612 ***

Note You need to log in before you can comment on or make changes to this bug.