Bug 734612 - Desktop running dog slow with certain applications
Desktop running dog slow with certain applications
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 731091 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 18:08 EDT by Paul F. Johnson
Modified: 2011-11-08 07:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-08 07:53:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2011-08-30 18:08:36 EDT
Description of problem:
Window redraw is incredibly slow with libreoffice and any mono application using winforms

Version-Release number of selected component (if applicable):
gnome-desktop3-3.1.5-1.fc16.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Run the rawhide libreoffice and select any menu
2. Run any winform mono application with a menu or dropdown box
3.
  
Actual results:
Redraw is incredibly slow with menu items or buttons (on modal windows) missing until the mouse goes over them

Expected results:
No slow down

Additional info:
Using the latest rawhide kernel on a machine with masses of empty drive space and 4Gb of memory (nice juicy video card in as well)
Comment 1 Richard Hughes 2011-08-31 04:48:53 EDT
Not gnome-desktop3, that's just a library for specific GNOME shared stuff. I'll reassign to libreoffice to see if one of them can help you debug this.
Comment 2 Caolan McNamara 2011-08-31 05:02:18 EDT
winform mono stuff is of course unrelated to libreoffice
Comment 3 Paul F. Johnson 2011-08-31 16:30:35 EDT
It happens with a number of other applications on gnome, but not under KDE or xfce with the same applications.
Comment 4 Caolan McNamara 2011-11-08 07:49:10 EST
*** Bug 731091 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2011-11-08 07:53:12 EST
Can't see a problem in GNOME on F-15 or F-16 with LibreOffice anyway with large or small icons. I'd blame some other component if I could guess where the problem lies. X is my usual suspect.

Note You need to log in before you can comment on or make changes to this bug.