Bug 731158 - Improve data and table columns on Sync Status page
Improve data and table columns on Sync Status page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Shannon Hughes
Katello QA List
: Improvement, Triaged
: 731937 (view as bug list)
Depends On:
Blocks: katello-blockers
  Show dependency treegraph
 
Reported: 2011-08-16 15:25 EDT by Jeff Weiss
Modified: 2014-11-09 17:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 13:52:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2011-08-16 15:25:26 EDT
Description of problem:
There are a couple of improvements that I think would make this page a lot easier to understand:

0) Remove the "Products" headline, it doesn't add any value.  Maybe "Last Sync" instead?
1) Change 'Progress' column header to 'Result'.  (Progress implies there's a sync in progress right now).  
 blank, [Progress bar], "Complete", "Error". We should never made statements about whether the product is currently in sync, we can't possibly know until we try to sync it. 'Not synced' needs to go away.
2) Change 'Finish Time' column to 'Duration', and show the amount of time the last sync took (if never synced, blank). If possible still show the duration even though it ended in an error, could help with troubleshooting.
3) Is the 'Est Size' column really an estimate?  Looks like the actual size to me.  If so, change to 'Size'.

Version-Release number of selected component (if applicable):
katello-0.1.63-1.git.30.3288de5.fc14.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Weiss 2011-08-19 11:12:53 EDT
*** Bug 731937 has been marked as a duplicate of this bug. ***
Comment 2 Shannon Hughes 2011-09-07 13:01:31 EDT
added syntax changes. waiting on a blocking bug to change/test the duration bullet point above.
Comment 3 Jeff Weiss 2011-10-19 08:57:27 EDT
Problem still remains that sync info disappears after an hour or so, but this is a pulp problem.  Will try to address that separately. 

Verified, katello-0.1.95-1.git.11.27446a9.el6.noarch
Comment 4 Og Maciel 2011-12-07 15:02:33 EST
Would it make more sense if Duration was blank (or in progress?) for running sync jobs? I found it a bit confusing to see the duration of my previous sync displaying in the active sync job...

Note You need to log in before you can comment on or make changes to this bug.