Bug 731211 - LUKSError: luks device not configured
Summary: LUKSError: luks device not configured
Keywords:
Status: CLOSED DUPLICATE of bug 727814
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d878de1b1b21beddb0e26b994e5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 00:29 UTC by Brian Lane
Modified: 2011-08-17 00:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 00:59:07 UTC


Attachments (Terms of Use)
Anaconda Traceback (361.25 KB, text/plain)
2011-08-17 00:33 UTC, Brian Lane
no flags Details

Description Brian Lane 2011-08-17 00:29:25 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         LUKSError: luks device not configured
time:           Tue Aug 16 13:27:41 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/luks.py", line 166, in setup
:    raise LUKSError("luks device not configured")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 84, in getLUKSPassphrase
:    device.format.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1175, in handleUdevLUKSFormat
:    self.__passphrases)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1598, in handleUdevDeviceFormat
:    self.handleUdevLUKSFormat(info, device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1031, in addUdevDevice
:    self.handleUdevDeviceFormat(info, device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1832, in _populate
:    self.addUdevDevice(dev)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1789, in populate
:    self._populate(progressWindow)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 474, in reset
:    cleanupOnly=cleanupOnly)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/autopart_type.py", line 157, in getNext
:    self.anaconda.storage.reset()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1194, in nextClicked
:    rc = self.currentWindow.getNext ()
:LUKSError: luks device not configured

Comment 1 Brian Lane 2011-08-17 00:33:05 UTC
Created attachment 518572 [details]
Anaconda Traceback

Comment 2 Brian Lane 2011-08-17 00:33:45 UTC
Installing over the top of a previously failed encrypted disk install. Selected cancel when prompted for the password for the old partition.

Comment 3 David Lehman 2011-08-17 00:59:07 UTC

*** This bug has been marked as a duplicate of bug 727814 ***


Note You need to log in before you can comment on or make changes to this bug.