Bug 731269 - Warning about nepomuk not running pops up on boot of F16 Alpha RC5 KDE live
Warning about nepomuk not running pops up on boot of F16 Alpha RC5 KDE live
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-08-17 04:25 EDT by Adam Williamson
Modified: 2011-10-19 00:40 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 07:41:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-08-17 04:25:54 EDT
When booting an F16 Alpha RC5 KDE live image, a warning message pops up a minute or two after boot, saying "nepomuk indexing agents have been disabled" because "nepomuk is not running". This is very easy to reproduce - grab http://dl.fedoraproject.org/pub/alt/stage/16-Alpha.RC5/Live/x86_64/Fedora-16-Alpha-x86_64-Live-KDE.iso and boot it.
Comment 1 Kevin Kofler 2011-08-17 06:43:01 EDT
Nepomuk SHOULD be running by default… Why is it not?
Comment 2 Kevin Kofler 2011-08-17 06:58:20 EDT
Darn, we explicitly disable Nepomuk for liveuser in the spin kickstart (fedora-live-kde-base.ks):

# Disable nepomuk
cat > /home/liveuser/.kde/share/config/nepomukserverrc << NEPOMUK_EOF
[Basic Settings]
Start Nepomuk=false

[Service-nepomukstrigiservice]
autostart=false
NEPOMUK_EOF

which is wrong. :-( In fact, it was already wrong on F15, but somehow we got away without a warning there as long as the user didn't fire up a kdepim app. In F16, Akonadi is now more integrated and the warning always fires.

IMHO, we should be disabling only Strigi indexing (i.e. the second part of the config file). Any objections to me changing that?

Is RC5 the gold image or will there be an RC6 (i.e. what will happen if I push a change to spin-kickstarts now, will it make the Alpha or not)?
Comment 4 Rex Dieter 2011-08-17 07:50:28 EDT
I object, I think.

Init'ing the nepomuk db on a live image is... bad.  We disabled this on purpose for good reason, it was a performance optimization.
Comment 5 Rex Dieter 2011-08-17 07:53:34 EDT
reading irc scrollback seems I'm in the minority here ok.

Ideally, performance could be restored if we could init the nepomuk db prior to liveuser first login... (same goes for akonadi and others...)
Comment 6 Kevin Kofler 2011-08-17 08:06:44 EDT
Do you have a better solution to propose?

We could hack the warning away, but…
Comment 7 Adam Williamson 2011-08-17 10:32:29 EDT
RC5's likely to be gold, Kev, this doesn't look like it infringes Alpha criteria, and we have no other open blockers.
Comment 8 nucleo 2011-09-01 12:49:32 EDT
F16 Beta LiveCD extremely slow because of high CPU usage by virtuoso-t (26%) and nepomukservices (49%) after enabling Nepomuk.

I think that Nepomuk warnings when it disabled are unnecessary because other apps (not from kdepim) that uses nepomuk works without such warnings.

So maybe it will be better to disable Nepomuk for better performance and patch out those warnings.
Comment 9 Tim Flink 2011-09-02 01:02:13 EDT
Proposing as a blocker for Fedora 16 beta because it interferes with the "desktop panel basic" testcase [1] that is part of the desktop beta test plan [2].

[1] https://fedoraproject.org/wiki/QA:Testcase_desktop_panel_basic
Comment 10 Kevin Kofler 2011-09-02 05:57:13 EDT
This is already fixed for F16 Beta. (It was fixed by a spin-kickstarts change, and the spins are composed from spin-kickstarts master.)
Comment 11 Rex Dieter 2011-10-13 10:39:10 EDT
OK, an alternative approach that should help make the live experience better:

* patched kde-settings/kdebase-workspace so default live login shouldn't even start akonadi (done, kde-settings-4.7-11+, kdebase-workspace-4.7.2-4+)

* patched kdepim-runtime to disable this spam'y notification (done kdepim-runtime-4.7.2-4+)

* disable nepomuk on live image, init'ing the virtuoso-db on a live image is *slow*.  to be done, if agreeable
Comment 12 Fedora Update System 2011-10-13 11:03:42 EDT
kdepim-runtime-4.7.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kdepim-runtime-4.7.2-3.fc16
Comment 13 Rex Dieter 2011-10-13 12:35:44 EDT
OK, so far got an ACK from than on irc to revert the nepomuk change in spin-kickstarts to make it disabled again.
Comment 14 Kevin Kofler 2011-10-13 14:07:40 EDT
So, I'm the one who made the spin-kickstarts change. Given your other changes, I'm OK with disabling Nepomuk again, IF AND ONLY IF:
* the 3 packages you touched (kde-settings, kdebase-workspace, kdepim-runtime) actually end up in F16 Final, and
* the patches are tested to actually work.
I also think that we should only change spin-kickstarts after the other packages are pushed, but I can be flexible on that, as long as everything ends up in F16 Final (see first point).

Now I think it's not a nice thing to do to our users to disable Plasma workspace features just because they happen to require Akonadi and/or Nepomuk. Users are going to miss the events runner and the events display in the clock plasmoid, which you disabled globally, even for installed systems. :-(
Comment 15 nucleo 2011-10-13 14:48:12 EDT
I tested kdepim-4.7.2-4.fc16 and kdepim-runtime-4.7.2-5.fc16 with disabled Nepomuk.

No more "Nepomuk Indexing Disabled" warnings after 20 minutes waiting.
Comment 16 nucleo 2011-10-14 12:53:06 EDT
There is problems with new kdepim updates (and maybe other builds with new qt 4.8) which have crashes. See bug 746252
Comment 17 Kevin Kofler 2011-10-15 14:34:06 EDT
So, an update of this:
* The kdebase-workspace patch is no longer needed with the latest kde-settings build.
* kde-settings-4.7-12.fc16 is needed: https://admin.fedoraproject.org/updates/FEDORA-2011-14234
* kdepim-4.7.2-5.fc16, kdepim-runtime-4.7.2-5.fc16 are needed: https://admin.fedoraproject.org/updates/FEDORA-2011-14260 but kdepim-runtime is built against the faulty Qt and should probably be rebuilt.

Once these go out, we can tweak the kickstart to stop running Nepomuk by default.
Comment 18 Kevin Kofler 2011-10-15 15:05:51 EDT
FEDORA-2011-14260 updated with a rebuilt kdepim-runtime-4.7.2-5.fc16.1.
Comment 19 Fedora Update System 2011-10-19 00:40:21 EDT
kdepim-4.7.2-5.fc16, kdepim-runtime-4.7.2-5.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.