Bug 746252 - Akregator built against qt 4.8 rc1 crashes
Akregator built against qt 4.8 rc1 crashes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Target-kde qt-4.8
  Show dependency treegraph
 
Reported: 2011-10-14 10:39 EDT by nucleo
Modified: 2013-10-04 08:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: qt-4.8.0-0.17.rc1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 03:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace for akregator crash (4.50 KB, text/plain)
2011-10-14 10:39 EDT, nucleo
no flags Details
backtrace for plasma-desktop crash (3.68 KB, text/plain)
2011-10-15 14:35 EDT, nucleo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-22037 None None None Never

  None (edit)
Description nucleo 2011-10-14 10:39:37 EDT
Created attachment 528218 [details]
backtrace for akregator crash

Description of problem:
Akregaror from kdepim 4.7.2 crashes when terminating if built against 
qt-4.8.0-0.12.20111002.fc16 or rc1 but works fine when built against 4.8 beta1.

Steps to Reproduce:
1. Start Akregator
2. Terminate it (File -> Close)
3.
  
Actual results:
Crash.

Additional info:
I tested kdepim-4.7.2-4 in F15 (built against qt 4.7.4) and in F16 (qt-4.8.0-0.12.20111002) but no crashes in F15.
In Rawhide more packages built using qt 4.8 20111002 snapshot and I noticed there other crashes in plasma when logging out but it is hard to reproduce them.
Comment 1 nucleo 2011-10-14 11:35:54 EDT
kdepim-4.7.2-1.fc16 built with qt 4.8 beta1 (is in F16 stable now) - is last buid which don't have crashes in akregator .
kdepim-4.7.2-4.fc16 built with 20111002 - have crashes but not because of notification patch because in F15 kdepim-4.7.2-4.fc15 works fine.
Comment 2 Kevin Kofler 2011-10-14 13:20:10 EDT
Can we tag the old Qt 4.8 Beta 1 build into our buildroot until this is fixed? We really need to build stuff for F16 Final ASAP, also a fix for:
https://bugs.kde.org/show_bug.cgi?id=283563
Comment 3 Rex Dieter 2011-10-14 13:31:14 EDT
ok, I'll tag the old one out of paranoia
Comment 4 Rex Dieter 2011-10-14 13:50:51 EDT
I can confirm akregator from kdepim-4.7.2-4.fc16 crashes on close too.
Comment 5 nucleo 2011-10-14 15:04:28 EDT
And again no crash with kdepim-4.7.2-5.fc16 built against qt-4.8.0-0.11.beta1.fc16
Comment 6 nucleo 2011-10-15 14:35:47 EDT
Created attachment 528340 [details]
backtrace for plasma-desktop crash

plasma-desktop also crashes in qlgorithms.h:322 (akonadi in qalgorithms.h:330) when kdebase-workspace built gaianst qt 4.8 snapshot.
Comment 7 Fedora Update System 2011-10-15 19:03:19 EDT
qt-4.8.0-0.15.rc1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-14348
Comment 8 Fedora Update System 2011-10-20 00:03:14 EDT
qt-4.8.0-0.17.rc1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Red Hat Bugzilla 2013-10-03 20:21:14 EDT
Removing external tracker bug with the id '22037' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.