Bug 731271 - TypeError: expected string or buffer
Summary: TypeError: expected string or buffer
Keywords:
Status: CLOSED DUPLICATE of bug 728883
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4da71a9aedaf5b10342aa1ce954...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 08:33 UTC by He Rui
Modified: 2011-08-17 13:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 13:13:56 UTC


Attachments (Terms of Use)
File: anaconda-tb-bmLo8t (179.53 KB, text/plain)
2011-08-17 08:33 UTC, He Rui
no flags Details

Description He Rui 2011-08-17 08:33:11 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         TypeError: expected string or buffer
time:           Wed Aug 17 08:34:40 2011
version:        16-Alpha

anaconda-tb-bmLo8t: Text file, 183841 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/re.py", line 137, in match
:    return _compile(pattern, flags).match(string)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/installclass.py", line 207, in archesEq
:    if re.match("i.86", a) and re.match("i.86", b):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/installclass.py", line 212, in productUpgradable
:    return self.productMatches(oldprod) and self.versionMatches(oldver) and archesEq(arch, productArch)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1524, in findExistingRootDevices
:    anaconda.instClass.productUpgradable(arch, product, version):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
:    upgradeany=flags.cmdline.has_key("upgradeany"))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:TypeError: expected string or buffer

Comment 1 He Rui 2011-08-17 08:33:15 UTC
Created attachment 518610 [details]
File: anaconda-tb-bmLo8t

Comment 2 He Rui 2011-08-17 09:04:56 UTC
It was triggered by accident that I haven't figured out the reproducible steps.

Comment 3 Chris Lumens 2011-08-17 13:13:56 UTC

*** This bug has been marked as a duplicate of bug 728883 ***


Note You need to log in before you can comment on or make changes to this bug.