Bug 728883 - TypeError: expected string or buffer
Summary: TypeError: expected string or buffer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 729511 731271 733286 733772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-08 09:32 UTC by Kamil Páral
Modified: 2014-09-30 23:40 UTC (History)
10 users (show)

Fixed In Version: anaconda-16.17-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-29 14:51:20 UTC


Attachments (Terms of Use)
logs (480.00 KB, application/x-tar)
2011-08-08 09:32 UTC, Kamil Páral
no flags Details
Logs from install (900.00 KB, application/x-tar)
2011-08-11 00:29 UTC, Timothy Davis
no flags Details

Description Kamil Páral 2011-08-08 09:32:07 UTC
Created attachment 517151 [details]
logs

Description of problem:
I received this after keyboard selection:

09:27:13,241 CRIT anaconda: anaconda 16.14.2 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/re.py", line 137, in match
    return _compile(pattern, flags).match(string)
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 207, in archesEq
    if re.match("i.86", a) and re.match("i.86", b):
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 212, in productUpgradable
    return self.productMatches(oldprod) and self.versionMatches(oldver) and archesEq(arch, productArch)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1511, in findExistingRootDevices
    anaconda.instClass.productUpgradable(arch, product, version):
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
    upgradeany=flags.cmdline.has_key("upgradeany"))
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
    self.anaconda.dispatch.go_forward()
TypeError: expected string or buffer

Version-Release number of selected component (if applicable):
anaconda 16.14.2

Comment 1 Kamil Páral 2011-08-08 09:35:20 UTC
Correction: This was after "examining storage devices" dialog. I happened again.

Comment 2 Chris Lumens 2011-08-08 14:00:19 UTC
What do you have installed on /dev/mapper/VolGroup-lv_root?  If it's a Fedora, what does /etc/fedora-release contain?

Comment 3 Kamil Páral 2011-08-08 14:21:05 UTC
The contents is "Fedora release 16 (Verne)".

Comment 4 Timothy Davis 2011-08-08 14:36:54 UTC
I ran into the same problem, I was trying to install on a plain SATA drive partition. I booted Fedora 16a RC1 from a usb drive

Comment 5 Ales Kozumplik 2011-08-10 06:54:43 UTC
*** Bug 729511 has been marked as a duplicate of this bug. ***

Comment 6 Timothy Davis 2011-08-11 00:29:02 UTC
Created attachment 517714 [details]
Logs from install

Here are my installation logs (tarred)
After examining storage devices anaconda crashed
System: Athlon FX-60, 2 Gb DDR, 160 Gb (Windows 7) IDE, 160 Gb Sata (swap/F15-64bit), 250 Gb Sata (boot, home)
Geforce 8500 GT 512Mb, Belkin wireless

Comment 7 Adam Williamson 2011-08-11 19:04:38 UTC
Kamil, were you also using a USB stick written with livecd-iso-to-disk ?

All reporters: what image did you write exactly? Live? DVD? boot.iso?

Comment 8 Timothy Davis 2011-08-11 19:11:40 UTC
I used livecd-iso-to-disk using the install DVD x86_64 iso image

Comment 9 Brian Lane 2011-08-11 23:52:42 UTC
When attaching logs please attach them as separate files, not a .tar

Comment 10 Kamil Páral 2011-08-12 09:59:11 UTC
(In reply to comment #7)
> Kamil, were you also using a USB stick written with livecd-iso-to-disk ?

No, I used DVD inside KVM machine (and previous install on disk was also from DVD).

(In reply to comment #9)
> When attaching logs please attach them as separate files, not a .tar

There are 11 usable log files in there. Since I have no insider knowledge of anaconda, I don't know what you might need. I prefer to extract the root cause (exception) and provide it in the summary, and then attach everything that could be usable to the report. Attaching 11 logs separately is time-consuming for me and cluttering up bugzilla for you (in case everyone does that, not just me).
But hey, I know mcepl has some pretty python scripts for automatically attaching large number of files. I can learn to use them. Just tell me what you need, I use the best effort/energy ratio approach now.

Comment 11 Timothy Davis 2011-08-14 04:51:30 UTC
I took the exact same iso image file (Fedora 16 Alpha RC3 x86_64) and burned a DVD with it (DVD+R) and it installed. Same image written to USB 4Gb with livecd-iso-to-disk and it would crash at examining storage devices.

Comment 12 Chris Lumens 2011-08-17 13:13:56 UTC
*** Bug 731271 has been marked as a duplicate of this bug. ***

Comment 13 Ales Kozumplik 2011-08-25 13:17:32 UTC
*** Bug 733286 has been marked as a duplicate of this bug. ***

Comment 14 Radek Vykydal 2011-08-29 08:35:19 UTC
*** Bug 733772 has been marked as a duplicate of this bug. ***

Comment 15 Ales Kozumplik 2011-08-30 14:22:40 UTC
This is reproducible when Anaconda is trying to determine upgradeability of a system that hasn't been completely installed.

Comment 16 Ales Kozumplik 2011-08-30 14:58:13 UTC
Fix posted: https://www.redhat.com/archives/anaconda-devel-list/2011-August/msg00394.html

Kamil, I prepared an updates image so if you are able to reproduce you can try with it: http://akozumpl.fedorapeople.org/bz728883.img. I think the reproducer could be starting the installer, doing partitioning and then force rebooting just before the package installation starts. Then without the updates image the next installation should show the traceback.

Comment 17 Ales Kozumplik 2011-08-31 08:01:24 UTC
Fixed pushed to f16-branch (8ca67447b20b0c4a54f8c720d61a0c9da9bb82d6) and master (e784b4b6e1b02dfdbab4fc45fccf9d13cc17c764).

Comment 18 Kamil Páral 2011-08-31 08:12:47 UTC
Aleš, I kept a disk image that caused the traceback. I tried your updates file on it and it doesn't traceback anymore in the first "examining storage devices" dialog. But it shows traceback later on when selecting partition layout. Automatic reporter marked it as duplicate of bug #693095. I'll attach the logs.

I don't know whether you fixed the bug or introduced another one by it.

04:05:51,084 CRIT anaconda: anaconda 16.14.6 exception report
Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/storage/devicelibs/lvm.py", line 400, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
  File "/tmp/updates/pyanaconda/storage/devices.py", line 2564, in _teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/tmp/updates/pyanaconda/storage/devices.py", line 761, in teardown
    self._teardown(recursive=recursive)
  File "/tmp/updates/pyanaconda/storage/deviceaction.py", line 283, in __init__
    device.teardown()
  File "/tmp/updates/pyanaconda/storage/__init__.py", line 917, in destroyDevice
    action = ActionDestroyDevice(device)
  File "/tmp/updates/pyanaconda/storage/partitioning.py", line 450, in clearPartitions
    storage.destroyDevice(leaf)
  File "/tmp/updates/pyanaconda/storage/partitioning.py", line 259, in doAutoPartition
    clearPartitions(anaconda.storage, bootloader=anaconda.bootloader)
  File "/tmp/updates/pyanaconda/dispatch.py", line 373, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/tmp/updates/pyanaconda/dispatch.py", line 241, in go_forward
    self.dispatch()
  File "/tmp/updates/pyanaconda/gui.py", line 1203, in nextClicked
    self.anaconda.dispatch.go_forward()
LVMError: lvdeactivate failed for lv_root:   LV VolGroup/lv_root in use: not deactivating

Comment 19 Kamil Páral 2012-02-29 14:51:20 UTC
This is a presumably solved F16 bug that I cannot reproduce with F17, closing.


Note You need to log in before you can comment on or make changes to this bug.