Bug 731345 - Javaws fails with bin/java not found
Summary: Javaws fails with bin/java not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: icedtea-web
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: Lukas Zachar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 12:06 UTC by Lukas Zachar
Modified: 2011-12-06 15:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:10:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1624 normal SHIPPED_LIVE icedtea-web enhancement update 2011-12-06 00:50:55 UTC

Description Lukas Zachar 2011-08-17 12:06:26 UTC
Description of problem:

When run javaws it fails with error:

/usr/bin/javaws: line 26: /usr/lib/jvm/java-1.6.0-openjdk.x86_64/bin/java: No such file or directory

Version-Release number of selected component (if applicable):
icedtea-web-1.1.1-1.el6.x86_64

How reproducible:
always


Steps to Reproduce:
1. run javaws
  
Actual results:
error

Expected results:
help message/correct run

Additional info:
tested with java-1.6.0-openjdk-1.6.0.0-1.40.1.10.3.el6.x86_64

there is no error when devel rpm is installed
(java-1.6.0-openjdk-devel-1.6.0.0-1.40.1.10.3.el6.x86_64)

Comment 2 Lukas Zachar 2011-08-17 12:17:36 UTC
With jre only, the java binary is located in
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java

Comment 3 Lukas Zachar 2011-08-17 12:44:48 UTC
There is similar problem with java plugin in BZ#731358

Comment 7 jiri vanek 2011-08-17 14:45:29 UTC
When quick-fix is quite easy and although also harmless, i suggest not to respin, and use this fix only when somebody complains.  Because it is very rare to have installed java without devel package.

Comment 11 errata-xmlrpc 2011-12-06 15:10:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1624.html


Note You need to log in before you can comment on or make changes to this bug.