Bug 731358 - Java plugin fails to load
Summary: Java plugin fails to load
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: icedtea-web
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Deepak Bhole
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
: 732373 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 12:40 UTC by Lukas Zachar
Modified: 2011-12-06 15:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:10:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1624 normal SHIPPED_LIVE icedtea-web enhancement update 2011-12-06 00:50:55 UTC

Description Lukas Zachar 2011-08-17 12:40:17 UTC
Description of problem:

When site with java applet is accessed, plugin fails to load with an error
"
/builddir/build/BUILD/icedtea-web-1.1.1/plugin/icedteanp/IcedTeaNPPlugin.cc:1500: thread 0x626830: Error: Failed to spawn applet viewer: Failed to execute child process "/usr/lib/jvm/java-1.6.0-openjdk.x86_64/jre/bin/java" (No such file or directory)
"

Version-Release number of selected component (if applicable):
icedtea-web-1.1.1-1.el6.x86_64

How reproducible:
always


Steps to Reproduce:
1. run firefox -g
2. visit site with applet 
(e.g. http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html)

  
Actual results:
error as in description

Expected results:
applet loads

Additional info:
Applet loads successfully, when devel rpm is installed.
(java-1.6.0-openjdk-devel-1.6.0.0-1.40.1.10.3.el6.x86_64)

Comment 1 Lukas Zachar 2011-08-17 12:42:55 UTC
Similar problem with javaws in bz#731345.

Comment 3 jiri vanek 2011-08-17 14:41:37 UTC
fixed by rhbz#731358 fix

Comment 5 Deepak Bhole 2011-08-23 14:41:03 UTC
*** Bug 732373 has been marked as a duplicate of this bug. ***

Comment 7 Deepak Bhole 2011-08-31 20:32:57 UTC
Not sure why this was flipped to fixed. It is not yet fixed.

Comment 11 errata-xmlrpc 2011-12-06 15:10:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1624.html


Note You need to log in before you can comment on or make changes to this bug.