Bug 731406 - when testing mesa via tuxracer or openarena second monitor will not fall back to running
Summary: when testing mesa via tuxracer or openarena second monitor will not fall back...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server-utils
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
: 729238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 14:50 UTC by Tomas Pelka
Modified: 2017-12-06 12:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 12:29:38 UTC


Attachments (Terms of Use)

Description Tomas Pelka 2011-08-17 14:50:33 UTC
Description of problem:
when executing mesa test which use e.g. openarena or tuxracer on dualhead, the game start cause that the secondary display will go off, that is ok, but quit the game will not fall the secondary display back on. I would assume that the display should be switched back on

Version-Release number of selected component (if applicable):
xorg-x11-server-utils-7.5-5.1.el6.x86_64
xorg-x11-drv-ati-6.14.2-6.el6.x86_64
kernel-2.6.32-184.el6.x86_64
mesa-dri-drivers-7.11-1.el6.x86_64
mesa-libGL-7.11-1.el6.x86_64
mesa-libGLU-7.11-1.el6.x86_64
mesa-libGLw-6.5.1-10.el6.x86_64
mesa-demos-7.11-1.el6.x86_64
mesa-libOSMesa-7.11-1.el6.x86_64

How reproducible:


Steps to Reproduce:
1. have dualhead configured
2. run tuxracer or openarena 
3. quit the game
4. watch the secondary monitor
  
Actual results:
secondary display stay off

Expected results:
secondary display should fall back to online

Additional info:
Don't think it is HW dependent, saw also on some Intels and nVidias.

Comment 2 Adam Jackson 2011-08-18 17:40:02 UTC
This is... subtle.  I don't think it's a regression from anything we've previously done, but I'm not sure it's desired either.

The issue, I think, is that SDL is using a Mesa GL extension for screen resizing, which Mesa implements with the XF86VidMode X extension internally.  VidMode has no notion of multihead.

I suspect to fix this we'd need to teach SDL to be much smarter about pushing and popping display state with RANDR.

Comment 3 Adam Jackson 2011-08-18 17:40:44 UTC
*** Bug 729238 has been marked as a duplicate of this bug. ***

Comment 5 RHEL Product and Program Management 2011-10-07 16:19:29 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Jan Kurik 2017-12-06 12:29:38 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.