Bug 731573 - Failed to fetch drift data
Failed to fetch drift data
Status: CLOSED DUPLICATE of bug 731889
Product: RHQ Project
Classification: Other
Component: Build System (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 707225 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-08-17 17:09 EDT by Mike Foley
Modified: 2011-08-19 09:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-19 09:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image of failed to fetch drift data (2.46 KB, application/octet-stream)
2011-08-17 17:09 EDT, Mike Foley
no flags Details
Image of failed to fetch drift data error (50.32 KB, image/png)
2011-08-17 17:11 EDT, Mike Foley
no flags Details
client-side error message of failed to fetch drift data (2.46 KB, text/plain)
2011-08-17 17:12 EDT, Mike Foley
no flags Details
server side logs (598.86 KB, application/octet-stream)
2011-08-17 17:20 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-08-17 17:09:19 EDT
Created attachment 518752 [details]
image of failed to fetch drift data

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Foley 2011-08-17 17:11:48 EDT
Created attachment 518753 [details]
Image of failed to fetch drift data error
Comment 2 Mike Foley 2011-08-17 17:12:57 EDT
Created attachment 518754 [details]
client-side error message of failed to fetch drift data
Comment 3 Mike Foley 2011-08-17 17:16:15 EDT
repro steps:

Drift--->History
Comment 4 Mike Foley 2011-08-17 17:20:01 EDT
Created attachment 518755 [details]
server side logs
Comment 5 Ian Springer 2011-08-18 16:42:49 EDT
Looks like DriftManagerBean.getServerPlugin() is returning null. I'll let Mazz or Jay dig into this one.
Comment 6 John Mazzitelli 2011-08-18 17:29:41 EDT
You are missing the drift server plugins. Something is wrong with the build. without the drift plugins, then this error is to be expected - but shoudl not happen. Those server plugins will always be there.

2011-08-17 13:24:41,169 INFO  [org.quartz.core.QuartzScheduler] Scheduler RHQServerPluginsJobs_$_NON_CLUSTERED started.
2011-08-17 13:24:42,570 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-operations]
2011-08-17 13:24:42,578 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [UrlContentSourcePlugin]
2011-08-17 13:24:42,581 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-mobicents]
2011-08-17 13:24:42,584 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-email]
2011-08-17 13:24:42,585 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [CorePerspective]
2011-08-17 13:24:42,587 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-subject]
2011-08-17 13:24:42,632 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [AntBundleServerPlugin]
2011-08-17 13:24:42,637 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [DiskContentSourcePlugin]
2011-08-17 13:24:42,659 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-cli]
2011-08-17 13:24:42,669 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [FileTemplateBundleServerPlugin]
2011-08-17 13:24:42,673 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-roles]
2011-08-17 13:24:42,673 INFO  [org.rhq.enterprise.server.plugin.pc.alert.AlertSenderPluginManager] Server plugin [alert-irc] is loaded but disabled
2011-08-17 13:24:42,673 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-irc]
2011-08-17 13:24:42,685 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [packagetype-cli]
2011-08-17 13:24:42,688 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [YumContentSourcePlugin]
2011-08-17 13:24:42,691 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-snmp]
2011-08-17 13:24:42,694 INFO  [org.rhq.enterprise.server.plugin.pc.MasterServerPluginContainer] Preloaded server plugin [alert-microblog]
2
Comment 7 John Mazzitelli 2011-08-18 17:35:23 EDT
confirmed the version of the distro used by QA is missing these plugins.

why did the automated builds not pick up the drift server plugins?
Comment 8 John Mazzitelli 2011-08-19 09:41:53 EDT

*** This bug has been marked as a duplicate of bug 731889 ***

Note You need to log in before you can comment on or make changes to this bug.