Bug 731801 - Section 4.1.1, review config instructions for jobserver, some steps may be redundant
Summary: Section 4.1.1, review config instructions for jobserver, some steps may be re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Deadline: 2011-10-10
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Management_Console_Installation_Guide
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: 2.1
: ---
Assignee: Alison Young
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On: 733205 738875
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 18:06 UTC by Trevor McKay
Modified: 2012-01-26 19:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-26 19:25:37 UTC


Attachments (Terms of Use)
BZ731801 content, revised instructions for job server config (14.45 KB, application/vnd.oasis.opendocument.text)
2011-10-07 02:22 UTC, Trevor McKay
no flags Details
BZ731801, tweak content (14.79 KB, application/vnd.oasis.opendocument.text)
2011-10-07 19:56 UTC, Trevor McKay
no flags Details
BZ731801, tweak again, switch order, change config file, modify verbage (14.73 KB, application/vnd.oasis.opendocument.text)
2011-10-07 21:02 UTC, Trevor McKay
no flags Details

Description Trevor McKay 2011-08-18 18:06:29 UTC
Description of problem:

Some of the steps in the jobserver config section may be unnecessary, review.

Comment 1 Alison Young 2011-08-19 01:20:28 UTC

*** This bug has been marked as a duplicate of bug 731799 ***

Comment 3 Trevor McKay 2011-08-19 13:10:39 UTC
The issue here is that some of the detailed parameter settings in "way 2" under section 4.1.1 are redundant considering out of the box configuration.  We should review and simplify the content in the box if appropriate.

It will work the way it is, it just may be more complex than needed.

Comment 4 Alison Young 2011-09-16 00:48:19 UTC
Hi Trevor, can you please review and suggest alternate content if deemed required. Setting needinfo deadline for 10 Oct.

Comment 5 Trevor McKay 2011-10-07 02:22:30 UTC
Created attachment 526821 [details]
BZ731801 content, revised instructions for job server config

Submissions should be published by the scheduler out of the box when condor-qmf is installed.  Nothing to do in the default case, this is option 1.

In the case of manual configuration of the daemon process, only 2 things must be done (will verify a second time on a clean system):  set QMF_PUBLISH_SUBMISSIONS to False and add JOB_SERVER to the daemon list.  There are other settings that could be changed but this is the minimal necessary set.  Since the 60condor-qmf.config file is there and contains everything but the QMF_PUBLISH_SUBMISSIONS line, I changed the instructions to edit that file.

Option three makes a plug for remote configuration.

In this current instruction set, then, only option #2 requires any file editing at all and that has been limited.

Comment 7 Trevor McKay 2011-10-07 02:29:30 UTC
Note, the attachment was made with change tracking on (set Changes->Show)

Comment 9 Trevor McKay 2011-10-07 19:56:22 UTC
Created attachment 526952 [details]
BZ731801, tweak content

Comment 10 Trevor McKay 2011-10-07 20:02:59 UTC
Sigh, typo in content.  The following sentence should change

"These configuration changes will take affect when condor is restarted."

to 

"These configuration changes will take effect when condor is (re)started."
                                                               ^
                                                               | maybe better?  
                                        ^                       
                                        |-- spelled effect wrong

Comment 13 Trevor McKay 2011-10-07 21:02:30 UTC
Created attachment 526967 [details]
BZ731801, tweak again, switch order, change config file, modify verbage

Switched the order of 2 and 3, moved additional lines to 40QMF.config rather than the rpm file.

Comment 17 Lubos Trilety 2011-11-28 14:28:21 UTC
Tiny issue found:
You can also add the modify the following:

probably should be

You can also add and modify the following:

Comment 18 Alison Young 2011-11-29 01:11:23 UTC
Change made in revision 1-18
Doc-stage: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/2/html-single/Management_Console_Installation_Guide/index.html#sect-Management_Console_Installation_Guide-Configuring_Grid-Setting_Job_Server_Configuration

Code snippets/comments:
<para>
	You can also add and modify the following:
</para>

Comment 19 Lubos Trilety 2011-11-29 14:11:34 UTC
Verified on Revision 1-18

Chapter 3.3.3. Setting Job Server Configuration was checked against provided information, no problem found.

>>> VERIFIED

Comment 20 Lana Brindley 2012-01-26 19:25:37 UTC
This book is now available on redhat.com/docs. Please raise a new bug if you spot any issues.

Thanks,
LKB


Note You need to log in before you can comment on or make changes to this bug.