Bug 731923 - RFE: entry or line numbers for the strings
RFE: entry or line numbers for the strings
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.3
Unspecified Unspecified
medium Severity medium
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-19 01:27 EDT by Hedda Peters
Modified: 2012-11-07 01:19 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.8-SNAPSHOT (20120731-0025)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 01:19:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2011-08-19 01:27:51 EDT
As a professional translator, I want to see entry or line numbers for the strings, so that I have a way of referring to a certain message within a document when discussing translation problems with other translators or writers.
Comment 1 Sean Flanigan 2011-09-07 00:33:31 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Noriko Mizumoto 2011-10-03 23:18:34 EDT
Version: Zanata version 1.4 (20111003-1100)

This feature has not been seen in updated version.
- No entry number makes translator unable to communicate certain string with others.
- No entry number makes translator unable to go back to certain string.

Finding one certain string in multiple pages without entry number is time consuming task, slowing translation speed.
Please raise the priority.
Comment 3 David Mason 2011-10-04 01:53:27 EDT
<damason> ping noriko: I have a question about entry/line numbers in zanata
<noriko> damason, pong
<damason> noriko: zanata 1.4 shows "Resource Id", which is a unique id within that document for the string. Is this the sort of thing you want?
<damason> or do you want something more like just row number?
<noriko> damason, theoretically it can work but it seems not practical....
<noriko> I mean too long.
<damason> noriko: would the value be used mainly for communicating with other translators, or to find an entry, or both?
<noriko> damason, both.
<noriko> ID also has no relation with previous or after. say referring #1 entry and then say 'let me see next entry' should refer to #2. this does not work for ID.
<damason> noriko, ok. I think showing line number in the "TRANS UNIT DETAILS" panel would not be very difficult. Showing it on the table for all rows would be more work, and making a feature to jump to a particular line would be a lot of work
<damason> noriko, so I think you could easily convince runa to add the first and maybe second of those things to the next sprint, the third should probably be a separate user story because it probably wouldn't add as much value for the amount of work it would be
Comment 4 Noriko Mizumoto 2011-10-04 03:59:34 EDT
Runa and damason

1) showing line number in the "TRANS UNIT DETAILS"
panel would not be very difficult

2) Showing it on the table for all rows would
be more work

3)  making a feature to jump to a particular line would be a lot
of work

From translators' perspective, it is very much appreciated that 1) is implemented, while IMHO it does not seem necessary having 2) if 1) is implemented. 3) is also useful and is used very frequent. It is much appreciated if 3) is considered too in the future.
Comment 6 Hedda Peters 2012-07-29 21:48:38 EDT
Hi, will this line numbering match the "row" numbering that is referred to in error messages?

Currently (1.7) when e.g. the save for an entry fails, Zanata displays a warning saying "[11:42:55] Save FAILED: row 278". 

While this is a useful warning, there is currently no way of looking up that particular row 278 to fix the problem. 

Will the line-numbering that is being implemented now allow me to go directly to the row that is being referenced in those notifications?
Comment 7 Ding-Yi Chen 2012-07-31 00:20:30 EDT
(In reply to comment #6)
> Hi, will this line numbering match the "row" numbering that is referred to
> in error messages?
> 
> Currently (1.7) when e.g. the save for an entry fails, Zanata displays a
> warning saying "[11:42:55] Save FAILED: row 278". 
> 
> While this is a useful warning, there is currently no way of looking up that
> particular row 278 to fix the problem. 
> 
> Will the line-numbering that is being implemented now allow me to go
> directly to the row that is being referenced in those notifications?

The feature you desire will definitly improve the efficiency. However, as this is out ot the scope of this bug. I would suggest this to be filed as a new RFE.

VERIFIED with Zanata version 1.8-SNAPSHOT (20120731-0025)
Comment 8 Ding-Yi Chen 2012-07-31 00:49:49 EDT
(In reply to comment #6)
> Hi, will this line numbering match the "row" numbering that is referred to
> in error messages?
> 
> Currently (1.7) when e.g. the save for an entry fails, Zanata displays a
> warning saying "[11:42:55] Save FAILED: row 278". 
> 
> While this is a useful warning, there is currently no way of looking up that
> particular row 278 to fix the problem. 
> 
> Will the line-numbering that is being implemented now allow me to go
> directly to the row that is being referenced in those notifications?

Bug 844553
Comment 9 Sean Flanigan 2012-11-07 01:19:33 EST
Fix released in Zanata 2.0.

Note You need to log in before you can comment on or make changes to this bug.