Bug 844553 - RFE- [WebTrans] Notification of an entry should have a link that go to the entry.
Summary: RFE- [WebTrans] Notification of an entry should have a link that go to the e...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI   
(Show other bugs)
Version: unspecified
Hardware: Unspecified Unspecified
medium
medium
Target Milestone: ---
: 2.3
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
Depends On: 723084
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-31 04:48 UTC by Ding-Yi Chen
Modified: 2013-11-27 03:34 UTC (History)
5 users (show)

Fixed In Version: 2.3-SNAPSHOT (20130410-1246)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 03:22:55 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 731923 None None None Never
Red Hat Bugzilla 844239 None None None Never

Description Ding-Yi Chen 2012-07-31 04:48:38 UTC
Description of problem:

Reword from https://bugzilla.redhat.com/show_bug.cgi?id=731923#c6 :

Currently (1.7) when e.g. the save for an entry fails, Zanata displays a warning saying "[11:42:55] Save FAILED: row 278". 

While this is a useful warning, there is currently no way of looking up that particular row 278 to fix the problem. 

Will the line-numbering that is being implemented now allow me to go directly to the row that is being referenced in those notifications?

Version-Release number of selected component (if applicable):
Zanata version 1.8-SNAPSHOT (20120731-0025)

Comment 1 Patrick Huang 2012-09-18 03:29:35 UTC
committed in master:
https://github.com/zanata/zanata/commit/6b04da6909f812eb5c565c56677c91ae95a7c3ea

Comment 2 Ding-Yi Chen 2012-09-20 07:33:13 UTC
Tested with Zanata version 1.8.0-SNAPSHOT (20120920-1415)
The row number and ID in notification shows correct.

However, this bug is about having a link to jump to the row, this function does not seems working. Thus reassigned.

Please change it to "WONTFIX" if such function won't be implemented.

Comment 3 Patrick Huang 2012-09-20 23:01:18 UTC
(In reply to comment #2)
> Tested with Zanata version 1.8.0-SNAPSHOT (20120920-1415)
> The row number and ID in notification shows correct.
> 
> However, this bug is about having a link to jump to the row, this function
> does not seems working. Thus reassigned.
> 
> Please change it to "WONTFIX" if such function won't be implemented.

The description says when save failed it should show a link to go back to the row. Therefore I only implement it to have link on failure not on success. If on success should also have link please update the description.

Comment 4 Patrick Huang 2012-09-21 05:11:09 UTC
committed in master:
https://github.com/zanata/zanata/commit/3607efc602d2f9214eb66fa5ff2d92ab3801acdc

Comment 5 Ding-Yi Chen 2012-09-25 02:10:24 UTC
Save FAILED is addressed by Bug 844239 - [WebTrans] WebUI shows "Save FAILED" on page 2 or later

This bug depends on Bug 723084 - RFE: bookmarkable messages, thus reassigned until bug 723084 is verified.

Comment 6 Alex Eng 2013-04-09 00:04:39 UTC
Implemented link to entry in notification.

See
https://github.com/zanata/zanata/commit/2d20903402406d6a23e3faeb07a0858ab5c17e7f

Comment 7 Ding-Yi Chen 2013-04-09 08:06:26 UTC
Tested with Zanata version 2.3-SNAPSHOT (20130409-1233)

It works fine within same document.

However, pressing the link from other document (even within same project) does nothing.

Reassigned

Comment 9 Ding-Yi Chen 2013-04-11 00:52:38 UTC
VERIFIED with Zanata version 2.3-SNAPSHOT (20130410-1246)

Comment 10 David Mason 2013-04-11 01:41:39 UTC
Found an issue that causes link to disappear, but the issue is more general so it is filed as a separate bug: https://bugzilla.redhat.com/show_bug.cgi?id=950806

Comment 11 Sean Flanigan 2013-11-27 03:12:49 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 12 Sean Flanigan 2013-11-27 03:14:59 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 13 Sean Flanigan 2013-11-27 03:17:48 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 14 Sean Flanigan 2013-11-27 03:22:55 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 15 Sean Flanigan 2013-11-27 03:32:24 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 16 Sean Flanigan 2013-11-27 03:34:41 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.


Note You need to log in before you can comment on or make changes to this bug.