Bug 73193 - rpm-4.1 hangs: unresponsive to ^C signals
rpm-4.1 hangs: unresponsive to ^C signals
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 75696 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 13:44 EDT by Jeff Johnson
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 14:30:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 2002-08-31 13:44:04 EDT
rpm-4.1 runs with signals blocked, hoping to get to
a "safe" point to exit (and close the database).
Comment 1 Jeff Johnson 2002-10-11 10:00:32 EDT
*** Bug 75696 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2002-12-17 14:30:28 EST
There's little reason to keep this bug open anymore.

The good news is that rpm-4.2-0.28nptl (probably, untested as
of this moment) fixes the stale lock problem.

The bad news is that you need to run a kernel that supplies
/dev/futex, and a version of glibc that supplies nptl.

Note You need to log in before you can comment on or make changes to this bug.