Bug 75696 - RPM 4.1-1.06 non-responsive to abort (control C) signal
RPM 4.1-1.06 non-responsive to abort (control C) signal
Status: CLOSED DUPLICATE of bug 73193
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 01:57 EDT by Doug
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 01:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug 2002-10-11 01:57:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461)

Description of problem:
When using rpm in RedHat 8.0, many operations that take a long time are not 
interruptable with the Control-C signal to abort the process.  Many times rpm 
does not acknowledge the Control-C until it's actually almost finished.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run something good like "rpm -qa"
2. As soon as it starts displaying all the installed packages, press CONTROL-C
3. (rpm will not stop)	

Actual Results:  In my case, rpm does NOT stop but continues to run until the 
end of the entire list of all installed packages.  Banging repeatedly on 
Control-C does not seem to help.
	

Expected Results:  When Control-C is pressed, rpm should stop/abort immediately.

Additional info:

In some cases, where rpm doesn't display large amount of output, but it's REAL 
busy doing stuff (like in "rpm -Vv kernel-sources", pressing control-c is 
useless.  If I need my console back, I can't get it, and I either have to start 
a new vt and kill -9 rpm, or just wait it out.

Not a serious bug, but VERY frustrating!  :)
Comment 1 Jeff Johnson 2002-10-11 10:00:38 EDT

*** This bug has been marked as a duplicate of 73193 ***
Comment 2 Doug 2002-10-12 01:19:52 EDT
Oops.  I *did* search to see if I was making a duplicate, but for some reason 
my search criteria didn't match bug 73193.  Could be because the summary 
of, "rpm-4.1 hangs: unresponsive to ^C signals" doesn't directly match "rpm" 
or "control-C" or "signal" as atomic words, which is what I think I searched on.

Oh, well, at least it's not just my system! :)
BB.

Note You need to log in before you can comment on or make changes to this bug.